summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c5377705a9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Sep 4 15:46:50 UTC 2017
+pkgbase = libpri
+ pkgdesc = library that encapsulates the protocols used to communicate over ISDN Primary Rate Interfaces
+ pkgver = 1.6.0
+ pkgrel = 1
+ url = http://www.asterisk.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = dahdi
+ source = https://downloads.asterisk.org/pub/telephony/libpri/libpri-1.6.0.tar.gz
+ sha256sums = 7225ea7ec334a115f9dc08e71f55589c38cb4e00b13964cd2f08cc4e6123e3f6
+
+pkgname = libpri
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dc90059b6405
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: twa022 <twa022 at gmail dot com>
+
+pkgname=libpri
+pkgver=1.6.0
+pkgrel=1
+pkgdesc='library that encapsulates the protocols used to communicate over ISDN Primary Rate Interfaces'
+arch=('i686' 'x86_64')
+url='http://www.asterisk.org/'
+license=('GPL')
+depends=('dahdi')
+source=("https://downloads.asterisk.org/pub/telephony/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('7225ea7ec334a115f9dc08e71f55589c38cb4e00b13964cd2f08cc4e6123e3f6')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}