summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be1d5cc83604..e4f3a0fc3bbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libqb-git
pkgdesc = Library with the primary purpose of providing high performance client server reusable features
- pkgver = 1.0.1.17.g75345a0
+ pkgver = 1.0.2.r0.g608de6d
pkgrel = 1
url = https://github.com/ClusterLabs/libqb
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b0b7c6590728..7c08407a9b90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libqb-git
_pkgname=libqb
-pkgver=1.0.1.17.g75345a0
+pkgver=1.0.2.r0.g608de6d
pkgrel=1
pkgdesc='Library with the primary purpose of providing high performance client server reusable features'
arch=("i686" "x86_64")
@@ -16,8 +16,8 @@ provides=('libqb')
conflicts=('libqb')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --tags | sed -e 's:v::' -e 's/-/./g'
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {