summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16075d8f093c..c8f9e3897cca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libqofono-git
pkgdesc = A library for accessing the ofono daemon, and a declarative plugin for it.
- pkgver = 0.103.r0.g047b667
+ pkgver = 0.1.r242.gb5f738b
pkgrel = 1
url = https://git.sailfishos.org/mer-core/libqofono
arch = x86_64
@@ -20,4 +20,3 @@ pkgbase = libqofono-git
sha512sums = SKIP
pkgname = libqofono-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 9ea13e093775..1e3d377d5b46 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gustavo Castro < gustawho [ at ] gmail [ dot ] com >
pkgname=libqofono-git
-pkgver=0.103.r0.g047b667
+pkgver=0.1.r242.gb5f738b
pkgrel=1
arch=('x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
pkgdesc="A library for accessing the ofono daemon, and a declarative plugin for it."
@@ -17,8 +17,8 @@ sha512sums=('SKIP')
pkgver() {
cd "${pkgname%-git}"
( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags --first-parent --match 'v[0-9][0-9.][0-9.]*' | \
+ sed 's=^v==;s=^\([0-9][0-9.]*\)-\([a-zA-Z]\+\)=\1\2=;s=\([0-9]\+-g\)=r\1=;s=-=.=g'
)
}
@@ -35,4 +35,4 @@ build() {
package() {
cd "${pkgname%-git}"/build
INSTALL_ROOT="${pkgdir}" make install
-} \ No newline at end of file
+}