summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rwxr-xr-xPKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1fb0e60646d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Dec 27 19:38:11 UTC 2015
+pkgbase = libquvi0.4
+ pkgdesc = Library for parsing flash media stream URLs with C API (version 0.4)
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = http://quvi.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ depends = libquvi-scripts0.4
+ depends = curl
+ depends = lua
+ provides = libquvi
+ conflicts = libquvi
+ source = http://sourceforge.net/projects/quvi/files/0.4/libquvi/libquvi-0.4.1.tar.xz
+ sha256sums = b5862f7e5fa6ed7defd169adb5c7586c6406af86e029671fd09615f6eb7aa903
+
+pkgname = libquvi0.4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..091fb93a4729
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Bermond < yahoo-com: danielbermond >
+
+# libquvi version 0.4.x (suitable for FFMpeg build).
+# FFmmpeg doesn't compile with libquvi version 0.9.x API, so it's necessary to use version 0.4.x.
+
+_srcname="libquvi"
+pkgname=libquvi0.4
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Library for parsing flash media stream URLs with C API (version 0.4)"
+arch=('i686' 'x86_64')
+url="http://quvi.sourceforge.net/"
+license=('LGPL2.1')
+depends=('libquvi-scripts0.4' 'curl' 'lua')
+provides=('libquvi')
+conflicts=('libquvi')
+source=("http://sourceforge.net/projects/quvi/files/0.4/libquvi/${_srcname}-${pkgver}.tar.xz")
+sha256sums=('b5862f7e5fa6ed7defd169adb5c7586c6406af86e029671fd09615f6eb7aa903')
+
+build() {
+ cd "$_srcname"-"$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_srcname"-"$pkgver"
+ make DESTDIR="$pkgdir/" install
+}