summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0198483c8a26..a17606f8456b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libraw-git
pkgdesc = A library for reading RAW files from digital cameras
- pkgver = 0.18.7.r211.g0df5490
+ pkgver = 0.21.1.r8.gf2998bac
pkgrel = 1
url = https://www.libraw.org/
arch = i686
@@ -11,11 +11,10 @@ pkgbase = libraw-git
depends = glibc
depends = jasper
depends = lcms2
- provides = libraw
+ provides = libraw=0.21.1.r8.gf2998bac
conflicts = libraw
options = staticlibs
source = git+https://github.com/LibRaw/LibRaw.git
sha256sums = SKIP
pkgname = libraw-git
-
diff --git a/PKGBUILD b/PKGBUILD
index bced887c6c3c..4f623e7f051d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libraw-git
-pkgver=0.18.7.r211.g0df5490
+pkgver=0.21.1.r8.gf2998bac
pkgrel=1
pkgdesc="A library for reading RAW files from digital cameras"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.libraw.org/"
license=('CDDL' 'LGPL')
depends=('glibc' 'jasper' 'lcms2')
makedepends=('git')
-provides=('libraw')
+provides=("libraw=$pkgver")
conflicts=('libraw')
options=('staticlibs')
source=("git+https://github.com/LibRaw/LibRaw.git")
@@ -22,14 +22,16 @@ pkgver() {
_tag=$(git tag -l --sort -v:refname | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/-/_/g'
}
build() {
cd "LibRaw"
autoreconf --install
- ./configure --prefix="/usr" --disable-examples
+ ./configure \
+ --prefix="/usr" \
+ --disable-examples
make
}