summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD70
3 files changed, 73 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74dfde5f3d8b..9731d3f24cfe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,30 @@
-# Generated by mksrcinfo v8
-# Fri Jun 14 09:14:31 UTC 2019
pkgbase = librepcb-git
pkgdesc = A free EDA software to develop printed circuit boards (git master)
- pkgver = r1683.e8586f91a
+ pkgver = r3220.8d5a2b1bd
pkgrel = 1
- url = http://librepcb.org/
+ url = https://librepcb.org/
arch = x86_64
arch = i686
license = GPL
makedepends = git
- depends = desktop-file-utils
+ makedepends = cmake
+ makedepends = pkg-config
+ makedepends = qt5-tools
+ makedepends = fontobene-qt5
+ makedepends = gtest
+ depends = glu
depends = hicolor-icon-theme
+ depends = muparser
+ depends = opencascade
+ depends = polyclipping
depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-quickcontrols2
+ depends = qt5-svg
+ depends = quazip
provides = librepcb
conflicts = librepcb
source = git+https://github.com/LibrePCB/LibrePCB
md5sums = SKIP
pkgname = librepcb-git
-
diff --git a/.gitignore b/.gitignore
index d6457d92b357..89e71560b3e1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,5 @@ pkg/
src/
*.swp
*.tar.xz
+*.tar.zst
LibrePCB/
diff --git a/PKGBUILD b/PKGBUILD
index 461399f71cac..2aa958413e79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,39 @@
# Maintainer: Danilo Bargen <aur at dbrgn dot ch>
+#
+# PGP key is on keyservers. To import:
+#
+# gpg --receive-keys 7EF3061F5C8D5E25
+#
+# See https://wiki.archlinux.org/index.php/Makepkg#Signature_checking
+# for more details # on package signing.
pkgname=librepcb-git
_fullname=LibrePCB
-pkgver=r1683.e8586f91a
+pkgver=r3220.8d5a2b1bd
pkgrel=1
pkgdesc="A free EDA software to develop printed circuit boards (git master)"
arch=('x86_64' 'i686')
-url="http://librepcb.org/"
+url="https://librepcb.org/"
license=('GPL')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'qt5-base')
-makedepends=('git')
+depends=(
+ 'glu'
+ 'hicolor-icon-theme'
+ 'muparser'
+ 'opencascade'
+ 'polyclipping'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-quickcontrols2'
+ 'qt5-svg'
+ 'quazip'
+)
+makedepends=(
+ 'git'
+ 'cmake'
+ 'pkg-config'
+ 'qt5-tools'
+ 'fontobene-qt5'
+ 'gtest'
+)
provides=('librepcb')
conflicts=('librepcb')
source=('git+https://github.com/LibrePCB/LibrePCB')
@@ -17,26 +42,45 @@ md5sums=('SKIP')
build() {
# Temporary build dir
rm -rf "$srcdir/$_fullname-build"
+ (cd "$srcdir/$_fullname" && git fetch)
git clone --recursive "$srcdir/$_fullname" "$srcdir/$_fullname-build"
cd "$srcdir/$_fullname-build"
- # Prepare
+ # Remove unbundled libs from source to ensure they're not used
+ rm -rf libs/fontobene-qt5/
+ rm -rf libs/muparser/
+ rm -rf libs/polyclipping/
+ rm -rf libs/quazip/
+ rm -rf libs/googletest/
+
+ # Remove bundled hoedown, it is not needed on Qt >=5.14
+ rm -rf libs/hoedown/
+
+ # Build
cd "$srcdir/$_fullname-build"
mkdir build && cd build
- qmake -r ../librepcb.pro PREFIX="${pkgdir}/usr"
-
- # Compile
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr" \
+ -DLIBREPCB_SHARE=/usr/share/librepcb \
+ -DUNBUNDLE_FONTOBENE_QT5=1 \
+ -DUNBUNDLE_MUPARSER=1 \
+ -DUNBUNDLE_POLYCLIPPING=1 \
+ -DUNBUNDLE_QUAZIP=1 \
+ -DUNBUNDLE_GTEST=1
make
}
+check() {
+ cd "$srcdir/$_fullname-build/build"
+
+ # Run unit tests
+ ./tests/unittests/librepcb-unittests
+}
+
package() {
cd "$srcdir/$_fullname-build/build"
make install
-
- # Install development utils
- install -s -m 755 \
- "output/uuid-generator" \
- "${pkgdir}/usr/bin/librepcb-uuid-generator"
}
pkgver() {