summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
-rw-r--r--librepcb-git.install16
2 files changed, 18 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bfb8332cddd5..085478a4b41f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=librepcb-git
_fullname=LibrePCB
pkgver=r549.95b8d1a
-pkgrel=1
+pkgrel=3
pkgdesc="LibrePCB is a free EDA software to develop printed circuit boards."
arch=('x86_64' 'i686')
url="http://librepcb.org/"
@@ -11,6 +11,7 @@ depends=('qt5-base' 'qt5-webkit' 'glu')
makedepends=('git' 'qconf')
provides=('librepcb')
conflicts=('librepcb')
+install=${pkgname}.install
source=('git+https://github.com/LibrePCB/LibrePCB')
md5sums=('SKIP')
diff --git a/librepcb-git.install b/librepcb-git.install
new file mode 100644
index 000000000000..423fbf48c248
--- /dev/null
+++ b/librepcb-git.install
@@ -0,0 +1,16 @@
+post_install() {
+ echo "Update icon cache..."
+ xdg-icon-resource forceupdate --theme hicolor &>/dev/null
+ echo "Update mime database..."
+ update-mime-database usr/share/mime &> /dev/null
+ echo "Update desktop database..."
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+post_remove() {
+ post_install "$1"
+}