summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b90692fc11e9..a7550d601f10 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = librespot-git
pkgdesc = Open Source Spotify client library
pkgver = 1383.095536f
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://github.com/librespot-org/librespot
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 942794201b07..0ba9d88c5d4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=librespot-git
_pkgname=librespot
pkgver=1383.095536f
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="Open Source Spotify client library"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -23,9 +23,15 @@ pkgver() {
prepare() {
cd "$_pkgname"
+
+ case "$CARCH" in
+ armv7h) target=armv7-unknown-linux-gnueabihf;;
+ *) target="$CARCH-unknown-linux-gnu";;
+ esac
+
cargo fetch \
--locked \
- --target "$CARCH-unknown-linux-gnu"
+ --target "$target"
}
build() {