summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa61532090cc..9afbd6f6313a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Sep 15 18:30:24 UTC 2017
+# Sat Sep 23 08:40:25 UTC 2017
pkgbase = librespot-git
pkgdesc = An open source client library for Spotify.
pkgver = 357.ddfc28f
@@ -11,7 +11,6 @@ pkgbase = librespot-git
license = MIT
makedepends = git
makedepends = cargo
- makedepends = portaudio
depends = rust
depends = protobuf
provides = librespot
diff --git a/PKGBUILD b/PKGBUILD
index 76fdc686514f..054b08fdcc43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@ arch=('i686' 'x86_64')
url="https://github.com/plietar/librespot"
license=('MIT')
depends=('rust' 'protobuf')
-makedepends=('git' 'cargo' 'portaudio')
+makedepends=('git' 'cargo')
provides=('librespot')
conflicts=('librespot')
source=('git+https://github.com/plietar/librespot'
@@ -28,6 +28,7 @@ build()
{
cd "$_pkgname"
cargo build \
+ --no-default-features \
--features alsa-backend \
--release
}