summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD49
-rw-r--r--aseprite.desktop11
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..89c1a687d5fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = libresprite
+ pkgdesc = fork of last GPL version of aseprite
+ pkgver = 1.1.7
+ pkgrel = 1
+ url = https://github.com/LibreSprite/LibreSprite
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = cmake
+ depends = pixman
+ depends = curl
+ depends = giflib
+ depends = zlib
+ depends = libpng
+ depends = libjpeg-turbo
+ depends = tinyxml
+ depends = freetype2
+ depends = libwebp
+ conflicts = aseprite
+ conflicts = aseprite-git
+ conflicts = aseprite-gpl
+ source = git+https://github.com/LibreSprite/LibreSprite.git#tag=v1.1.7
+ source = aseprite.desktop
+ sha256sums = SKIP
+ sha256sums = d234924baf107e8ede619261814f5debbb1835bd59ffda5e5bf76fe62ce139ab
+
+pkgname = libresprite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f2c51e0e10ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Kuba Kowalik <bell@0x07.pl>
+
+pkgname=libresprite
+pkgver=1.1.7
+pkgrel=1
+pkgdesc='fork of last GPL version of aseprite'
+arch=('x86_64' 'i686')
+url='https://github.com/LibreSprite/LibreSprite'
+license=('GPL')
+depends=('pixman' 'curl' 'giflib' 'zlib' 'libpng' 'libjpeg-turbo' 'tinyxml' 'freetype2' 'libwebp')
+makedepends=('cmake')
+source=("git+https://github.com/LibreSprite/LibreSprite.git#tag=v${pkgver}"
+ "aseprite.desktop")
+sha256sums=('SKIP'
+ 'd234924baf107e8ede619261814f5debbb1835bd59ffda5e5bf76fe62ce139ab')
+conflicts=(aseprite aseprite-git aseprite-gpl)
+
+build() {
+ cd "LibreSprite"
+ mkdir -p build && cd build
+ git submodule update --init --recursive
+ cmake -DUSE_SHARED_PIXMAN=ON \
+ -DWITH_WEBP_SUPPORT=ON \
+ -DUSE_SHARED_LIBWEBP=ON \
+ -DUSE_SHARED_CURL=ON \
+ -DUSE_SHARED_GIFLIB=ON \
+ -DUSE_SHARED_JPEGLIB=ON \
+ -DUSE_SHARED_ZLIB=ON \
+ -DUSE_SHARED_LIBPNG=ON \
+ -DUSE_SHARED_LIBLOADPNG=OFF \
+ -DUSE_SHARED_TINYXML=ON \
+ -DENABLE_UPDATER=OFF \
+ -DUSE_SHARED_FREETYPE=ON \
+ -DFREETYPE_INCLUDE_DIR=/usr/include/freetype2 \
+ -DCMAKE_INSTALL_PREFIX:STRING=/usr ..
+ make aseprite
+}
+
+package() {
+ cd "LibreSprite"/build
+
+ make DESTDIR="$pkgdir/" install/fast
+ install -Dm644 "$srcdir/aseprite.desktop" \
+ "$pkgdir/usr/share/applications/aseprite.desktop"
+ install -Dm644 "../data/icons/ase48.png" \
+ "$pkgdir/usr/share/pixmaps/aseprite.png"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/aseprite.desktop b/aseprite.desktop
new file mode 100644
index 000000000000..1eb29fe6dd09
--- /dev/null
+++ b/aseprite.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Encoding=UTF-8
+Name=Aseprite
+Comment=Sprite and pixelart software
+MimeType=image/bmp;image/gif;image/jpeg;image/png;image/x-pcx;image/x-tga;image/vnd.microsoft.icon;video/x-flic;image/webp;image/x-aseprite;
+Exec=aseprite %U
+Terminal=false
+Categories=Graphics;2DGraphics;RasterGraphics;
+Icon=aseprite
+X-Desktop-File-Install-Version=0.22