summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD77
2 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d72f51c5987
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+# Generated by mksrcinfo v8
+# Sun Jun 18 19:39:07 UTC 2017
+pkgbase = libretro-citra-git
+ pkgdesc = Nintendo 3DS core
+ pkgver = r4851.ae8cfe69
+ pkgrel = 1
+ url = https://github.com/libretro/citra
+ arch = i686
+ arch = x86_64
+ groups = libretro
+ license = GPL2
+ makedepends = boost
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ provides = libretro-citra
+ conflicts = libretro-citra
+ source = libretro-citra::git+https://github.com/libretro/citra.git
+ source = git+https://github.com/philsquared/Catch#tag=v1.9.5
+ source = git+https://github.com/weidai11/cryptopp
+ source = git+https://github.com/MerryMage/dynarmic
+ source = git+https://github.com/fmtlib/fmt#tag=3.0.2
+ source = git+https://github.com/svn2github/inih
+ source = git+https://github.com/neobrain/nihstro
+ source = citra-soundtouch::git+https://github.com/citra-emu/ext-soundtouch
+ source = git+https://github.com/herumi/xbyak#tag=v5.43
+ source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/citra_libretro.info
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = a9404c4eb4fb8a4caca9efbbd764bd272381a7a6f4378a05e956e3efbe4ba79e
+
+pkgname = libretro-citra-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a854560daa61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,77 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libretro-citra-git
+pkgver=r4851.ae8cfe69
+pkgrel=1
+pkgdesc='Nintendo 3DS core'
+arch=('i686' 'x86_64')
+url='https://github.com/libretro/citra'
+license=('GPL2')
+groups=('libretro')
+depends=('gcc-libs' 'glibc')
+makedepends=('boost' 'git')
+provides=('libretro-citra')
+conflicts=('libretro-citra')
+source=('libretro-citra::git+https://github.com/libretro/citra.git'
+ 'git+https://github.com/philsquared/Catch#tag=v1.9.5'
+ 'git+https://github.com/weidai11/cryptopp'
+ 'git+https://github.com/MerryMage/dynarmic'
+ 'git+https://github.com/fmtlib/fmt#tag=3.0.2'
+ 'git+https://github.com/svn2github/inih'
+ 'git+https://github.com/neobrain/nihstro'
+ 'citra-soundtouch::git+https://github.com/citra-emu/ext-soundtouch'
+ 'git+https://github.com/herumi/xbyak#tag=v5.43'
+ 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/citra_libretro.info')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'a9404c4eb4fb8a4caca9efbbd764bd272381a7a6f4378a05e956e3efbe4ba79e')
+
+pkgver() {
+ cd libretro-citra
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd libretro-citra
+
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
+ mkdir build
+
+ for submodule in externals/{catch,cryptopp/cryptopp,dynarmic,fmt,inih/inih,nihstro,soundtouch,xbyak}; do
+ git submodule init ${submodule}
+ git config submodule.${submodule}.url ../${submodule##*/}
+ git submodule update
+ done
+}
+
+build() {
+ cd libretro-citra/build
+
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_PREFIX='/usr' \
+ -DDISABLE_LIBPNG='ON' \
+ -DENABLE_LIBRETRO='ON' \
+ -DENABLE_QT='OFF' \
+ -DENABLE_SDL2='OFF'
+ make
+}
+
+package() {
+ cd libretro-citra/build
+
+ install -Dm 644 src/citra_libretro/citra_libretro.so -t "${pkgdir}"/usr/lib/libretro/
+ install -Dm 644 ../../citra_libretro.info -t "${pkgdir}"/usr/share/libretro/info/
+}
+
+# vim: ts=2 sw=2 et: