summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b97f3aa5d7e..fb0dbe63315c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Fri Dec 22 14:52:44 UTC 2017
+# Mon Mar 26 21:18:40 UTC 2018
pkgbase = libretro-citra-git
pkgdesc = Nintendo 3DS core
- pkgver = r5381.4b0ec7ec
+ pkgver = r5903.7f983fe7
pkgrel = 1
url = https://github.com/libretro/citra
- arch = i686
arch = x86_64
groups = libretro-unstable
license = GPL2
makedepends = cmake
makedepends = git
- depends = curl
depends = gcc-libs
depends = glibc
depends = libretro-core-info
+ depends = sdl2
+ depends = libcurl.so
provides = libretro-citra
conflicts = libretro-citra
source = libretro-citra::git+https://github.com/libretro/citra.git
diff --git a/PKGBUILD b/PKGBUILD
index d9dc3ccc3014..ce3e2838aa11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=libretro-citra-git
-pkgver=r5381.4b0ec7ec
+pkgver=r5903.7f983fe7
pkgrel=1
pkgdesc='Nintendo 3DS core'
arch=('x86_64')
url='https://github.com/libretro/citra'
license=('GPL2')
groups=('libretro-unstable')
-depends=('curl' 'gcc-libs' 'glibc' 'libretro-core-info')
+depends=('gcc-libs' 'glibc' 'libretro-core-info' 'sdl2'
+ 'libcurl.so')
makedepends=('cmake' 'git')
provides=('libretro-citra')
conflicts=('libretro-citra')
@@ -68,10 +69,9 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE='Release' \
- -DDISABLE_LIBPNG='ON' \
-DENABLE_LIBRETRO='ON' \
-DENABLE_QT='OFF' \
- -DENABLE_SDL2='OFF' \
+ -DENABLE_SDL2='ON' \
-DUSE_SYSTEM_CURL='ON'
make
}