summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD37
2 files changed, 22 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f32845b635fa..c9ca6563ac83 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sat Dec 23 22:36:53 UTC 2017
pkgbase = libretro-genesis-plus-gx-git
- pkgdesc = libretro implementation of Genesis Plus GX. (Sega Master System/Sega Game Gear/Sega Mega Drive/Sega Genesis/Sega CD)
- pkgver = 1366.5c515fb
+ pkgdesc = Sega 8/16 bit emu - Genesis Plus (enhanced) port for libretro (Sega MS/GG/MD/CD)
+ pkgver = 1459.7856b72
pkgrel = 1
url = https://github.com/libretro/Genesis-Plus-GX
arch = i686
@@ -13,11 +11,9 @@ pkgbase = libretro-genesis-plus-gx-git
groups = libretro
license = custom
makedepends = git
- depends = zlib
- depends = libretro-core-info
- conflicts = libretro-genplus-git
+ depends = glibc
source = git+https://github.com/libretro/Genesis-Plus-GX.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = libretro-genesis-plus-gx-git
diff --git a/PKGBUILD b/PKGBUILD
index 2b1b3f7d5895..8548bd84a45e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
-# Maintainer : Johnathan Jenkins <twodopeshaggy@gmail.com>
-# Contributor: prettyvanilla <prettyvanilla@posteo.at>
+# Maintainer: Mike Polvere <mic.tjs@gmail.com>
+# Contributor: Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: prettyvanilla <prettyvanilla@posteo.at>
# Contributor: almostalive <almostalive2003 at gmail dot com>
pkgname=libretro-genesis-plus-gx-git
-pkgver=1366.5c515fb
+pkgver=1459.7856b72
pkgrel=1
-pkgdesc="libretro implementation of Genesis Plus GX. (Sega Master System/Sega Game Gear/Sega Mega Drive/Sega Genesis/Sega CD)"
+pkgdesc='Sega 8/16 bit emu - Genesis Plus (enhanced) port for libretro (Sega MS/GG/MD/CD)'
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h')
-groups=('libretro')
-url="https://github.com/libretro/Genesis-Plus-GX"
-license=('custom')
-conflicts=('libretro-genplus-git')
-depends=('zlib' 'libretro-core-info')
-makedepends=('git')
-
_libname=genesis_plus_gx_libretro
_gitname=Genesis-Plus-GX
+url="https://github.com/libretro/${_gitname}"
+license=('custom')
+groups=('libretro')
+depends=('glibc')
+makedepends=('git')
source=("git+https://github.com/libretro/${_gitname}.git")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "${_gitname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd "${_gitname}"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
build() {
- cd "${_gitname}"
- make -f Makefile.libretro
+ cd "${_gitname}"
+ make -f Makefile.libretro
}
package() {
- install -Dm644 "${_gitname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
-}
+ install -Dm644 "${_gitname}/${_libname}.so" "${pkgdir}/usr/lib/libretro/${_libname}.so"
+ install -Dm644 "${_gitname}/LICENSE.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}