summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD9
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45e9f5178762..a79fd3e7cbb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libretro-neocd-git
pkgdesc = SNK Neo Geo CD core
- pkgver = r135.327aece
+ pkgver = r145.2070f52
pkgrel = 1
url = https://github.com/libretro/neocd_libretro
arch = aarch64
@@ -12,10 +12,11 @@ pkgbase = libretro-neocd-git
groups = libretro
license = LGPL3
makedepends = git
+ makedepends = libchdr
+ makedepends = libvorbis
depends = gcc-libs
- depends = libchdr
+ depends = glibc
depends = libretro-core-info
- depends = libvorbis
depends = zlib
provides = libretro-neocd
conflicts = libretro-neocd
@@ -25,3 +26,9 @@ pkgbase = libretro-neocd-git
b2sums = de8c8053444f1dff288ee28f2e28eeee99900b5e90d03598f8b4ebf993707ee27c65ca7b8854abcac06ab356987b90586de9277d774a3557b0641fe995fe036c
pkgname = libretro-neocd-git
+ depends = gcc-libs
+ depends = glibc
+ depends = libretro-core-info
+ depends = zlib
+ depends = libchdr.so
+ depends = libvorbisfile.so
diff --git a/PKGBUILD b/PKGBUILD
index fcbc36539922..74fe5059d917 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Oliver Jaksch <arch-aur at com-in dot de>
_pkgname=libretro-neocd
pkgname=$_pkgname-git
-pkgver=r135.327aece
+pkgver=r145.2070f52
pkgrel=1
pkgdesc="SNK Neo Geo CD core"
arch=('aarch64' 'armv7h' 'i486' 'i686' 'pentium4' 'x86_64')
url="https://github.com/libretro/neocd_libretro"
license=('LGPL3')
groups=('libretro')
-depends=('gcc-libs' 'libchdr' 'libretro-core-info' 'libvorbis' 'zlib')
-makedepends=('git')
+depends=('gcc-libs' 'glibc' 'libretro-core-info' 'zlib')
+makedepends=('git' 'libchdr' 'libvorbis')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=(
@@ -39,6 +39,7 @@ build() {
}
package() {
+ depends+=('libchdr.so' 'libvorbisfile.so')
# shellcheck disable=SC2154
- install -Dm644 -t "$pkgdir"/usr/lib/libretro $_pkgname/neocd_libretro.so
+ install -D -t "$pkgdir"/usr/lib/libretro $_pkgname/neocd_libretro.so
}