summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 8 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9ed963e516f5..23e611e004a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Sep 24 11:25:43 UTC 2017
+# Fri Dec 22 15:06:45 UTC 2017
pkgbase = libretro-nestopia-git
pkgdesc = Nintendo Entertainment System core
- pkgver = r828.071f04e
+ pkgver = r851.e4b6750
pkgrel = 1
url = https://github.com/libretro/nestopia
arch = i686
@@ -12,12 +12,11 @@ pkgbase = libretro-nestopia-git
makedepends = git
depends = gcc-libs
depends = glibc
+ depends = libretro-core-info
provides = libretro-nestopia
conflicts = libretro-nestopia
source = libretro-nestopia::git+https://github.com/libretro/nestopia.git
- source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/nestopia_libretro.info
sha256sums = SKIP
- sha256sums = eef5ed9b47c0189d03522a69265b96148f5a5e20fcb816b756443f436edc75a8
pkgname = libretro-nestopia-git
diff --git a/PKGBUILD b/PKGBUILD
index 630c8f256d18..ea2a7f4d37a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,19 @@
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
pkgname=libretro-nestopia-git
-pkgver=r828.071f04e
+pkgver=r851.e4b6750
pkgrel=1
pkgdesc='Nintendo Entertainment System core'
arch=('i686' 'x86_64')
url='https://github.com/libretro/nestopia'
license=('GPL2')
groups=('libretro-unstable')
-depends=('gcc-libs' 'glibc')
+depends=('gcc-libs' 'glibc' 'libretro-core-info')
makedepends=('git')
provides=('libretro-nestopia')
conflicts=('libretro-nestopia')
-source=('libretro-nestopia::git+https://github.com/libretro/nestopia.git'
- 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/nestopia_libretro.info')
-sha256sums=('SKIP'
- 'eef5ed9b47c0189d03522a69265b96148f5a5e20fcb816b756443f436edc75a8')
+source=('libretro-nestopia::git+https://github.com/libretro/nestopia.git')
+sha256sums=('SKIP')
pkgver() {
cd libretro-nestopia
@@ -34,9 +32,7 @@ build() {
package() {
cd libretro-nestopia/libretro
- install -dm 755 "${pkgdir}"/usr/{lib/libretro,share/libretro/info}
- install -m 644 nestopia_libretro.so "${pkgdir}"/usr/lib/libretro/
- install -m 644 ../../nestopia_libretro.info "${pkgdir}"/usr/share/libretro/info/
+ install -Dm 644 nestopia_libretro.so -t "${pkgdir}"/usr/lib/libretro/
}
# vim: ts=2 sw=2 et: