summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--MKPKG5
-rw-r--r--PKGBUILD40
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c857bdec8fd5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = libretro-nestopia-git
+ pkgdesc = Nestopia libretro core
+ pkgver = r586.4ee529f
+ pkgrel = 1
+ url = https://github.com/libretro/nestopia
+ arch = i686
+ arch = x86_64
+ groups = libretro
+ license = GPL2
+ makedepends = git
+ depends = gcc-libs
+ depends = glibc
+ provides = libretro-nestopia
+ conflicts = libretro-nestopia
+ source = libretro-nestopia::git+https://github.com/libretro/nestopia.git
+ source = https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/nestopia_libretro.info
+ sha256sums = SKIP
+ sha256sums = eea21d5c2fb0fe95c2f84c8e957b18a7898699a3899e784f94feb87f68c847b1
+
+pkgname = libretro-nestopia-git
+
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..6f223d0a3d72
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,5 @@
+pkgname=('libretro-nestopia-git')
+
+check_git $packagedir/$pkgname/${pkgname%-*}
+
+# vim: ts=2 sw=2 et:
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..536278712b77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
+
+pkgname=libretro-nestopia-git
+pkgver=r586.4ee529f
+pkgrel=1
+pkgdesc='Nestopia libretro core'
+arch=('i686' 'x86_64')
+url='https://github.com/libretro/nestopia'
+license=('GPL2')
+groups=('libretro')
+depends=('gcc-libs' 'glibc')
+makedepends=('git')
+provides=('libretro-nestopia')
+conflicts=('libretro-nestopia')
+source=('libretro-nestopia::git+https://github.com/libretro/nestopia.git'
+ 'https://raw.githubusercontent.com/libretro/libretro-super/master/dist/info/nestopia_libretro.info')
+sha256sums=('SKIP'
+ 'eea21d5c2fb0fe95c2f84c8e957b18a7898699a3899e784f94feb87f68c847b1')
+
+pkgver() {
+ cd libretro-nestopia
+
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd libretro-nestopia/libretro
+
+ make
+}
+
+package() {
+ cd libretro-nestopia/libretro
+
+ install -dm 755 "${pkgdir}"/usr/{lib/libretro,share/libretro/info}
+ install -m 644 nestopia_libretro.so "${pkgdir}"/usr/lib/libretro/
+ install -m 644 ../../nestopia_libretro.info "${pkgdir}"/usr/share/libretro/info/
+}
+
+# vim: ts=2 sw=2 et: