summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebef671d3924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libretro-pcsx2-git
+ pkgdesc = Launch Sony PlayStation 2 games through PCSX2, directly from RetroArch.
+ pkgver = 46.bc78bf9
+ pkgrel = 1
+ url = https://github.com/coldscientist/libretro-pcsx2-launcher
+ arch = x86_64
+ groups = libretro
+ license = MIT
+ makedepends = git
+ depends = pcsx2
+ depends = libretro-core-info
+ provides = libretro-pcsx2
+ conflicts = libretro-pcsx2
+ source = libretro-pcsx2::git+https://github.com/coldscientist/libretro-pcsx2-launcher.git
+ sha256sums = SKIP
+
+pkgname = libretro-pcsx2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0850590c6bbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Eugene Lebedev <satanych13+dev@gmail.com>
+
+pkgname=libretro-pcsx2-git
+pkgver=46.bc78bf9
+pkgrel=1
+pkgdesc="Launch Sony PlayStation 2 games through PCSX2, directly from RetroArch."
+arch=('x86_64')
+url="https://github.com/coldscientist/libretro-pcsx2-launcher"
+license=('MIT')
+conflicts=('libretro-pcsx2')
+provides=('libretro-pcsx2')
+depends=('pcsx2' 'libretro-core-info')
+makedepends=('git')
+groups=('libretro')
+
+source=("libretro-pcsx2::git+https://github.com/coldscientist/libretro-pcsx2-launcher.git")
+
+sha256sums=(SKIP)
+
+pkgver() {
+ cd libretro-pcsx2
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd libretro-pcsx2
+ make
+}
+
+package() {
+ install -Dm644 libretro-pcsx2/dolphin_launcher_libretro.so "${pkgdir}/usr/lib/libretro/pcsx2_launcher_libretro.so"
+ install -Dm644 libretro-pcsx2/dolphin_launcher_libretro.info "${pkgdir}/usr/share/libretro/info/pcsx2_launcher_libretro.info"
+}
+