summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Do-not-vendor-the-pugixml-library.patch56
-rw-r--r--PKGBUILD4
3 files changed, 53 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd5a896996c3..a31450e5aa19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libsavitar-git
pkgdesc = c++ implementation of 3mf loading with SIP python bindings
pkgver = 4.9.beta.r0.gfe88675
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Ultimaker/libSavitar
arch = i686
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = libsavitar-git
source = git+https://github.com/Ultimaker/libSavitar.git
source = 0001-Do-not-vendor-the-pugixml-library.patch
md5sums = SKIP
- md5sums = 1d0e2c14874414202eba249d956ada56
+ md5sums = 6a59f74447a366e9b71d294b916e5cc6
pkgname = libsavitar-git
diff --git a/0001-Do-not-vendor-the-pugixml-library.patch b/0001-Do-not-vendor-the-pugixml-library.patch
index 8b9834725ab5..5a0dc7b942b8 100644
--- a/0001-Do-not-vendor-the-pugixml-library.patch
+++ b/0001-Do-not-vendor-the-pugixml-library.patch
@@ -1,4 +1,4 @@
-From c436082126399a8b48ea763f26a3d1434b40728f Mon Sep 17 00:00:00 2001
+From 021d0732750cddee97e771814e5e2ca17585db46 Mon Sep 17 00:00:00 2001
From: Eli Schwartz <eschwartz93@gmail.com>
Date: Mon, 9 Apr 2018 12:36:35 -0400
Subject: [PATCH] Do not vendor the pugixml library
@@ -8,12 +8,15 @@ libraries, and also fixes the includes for pugixml.hpp to actually use
the include path added by find_package/add_subdirectory instead of a
hardcoded relative path.
---
- CMakeLists.txt | 2 +-
- src/MeshData.cpp | 2 +-
- src/Scene.cpp | 2 +-
- src/SceneNode.cpp | 2 +-
- src/ThreeMFParser.h | 2 +-
- 5 files changed, 5 insertions(+), 5 deletions(-)
+ CMakeLists.txt | 2 +-
+ src/MeshData.cpp | 2 +-
+ src/Namespace.cpp | 2 +-
+ src/Scene.cpp | 2 +-
+ src/SceneNode.cpp | 2 +-
+ src/ThreeMFParser.h | 2 +-
+ tests/MeshDataTest.cpp | 2 +-
+ tests/NamespaceTest.cpp | 2 +-
+ 8 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f22d42e..e78b1f8 100644
@@ -41,6 +44,19 @@ index 97c089a..7c4de46 100644
#include <cstring>
#include <iostream>
#include <stdexcept> //For std::runtime_error.
+diff --git a/src/Namespace.cpp b/src/Namespace.cpp
+index 2cfff76..23c3349 100644
+--- a/src/Namespace.cpp
++++ b/src/Namespace.cpp
+@@ -3,7 +3,7 @@
+
+ #include "Namespace.h"
+
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+
+ namespace xml_namespace
+ {
diff --git a/src/Scene.cpp b/src/Scene.cpp
index 7a40570..86e9295 100644
--- a/src/Scene.cpp
@@ -80,6 +96,32 @@ index 3394683..a0f6691 100644
#include <string>
namespace Savitar
+diff --git a/tests/MeshDataTest.cpp b/tests/MeshDataTest.cpp
+index 583b946..76d3187 100644
+--- a/tests/MeshDataTest.cpp
++++ b/tests/MeshDataTest.cpp
+@@ -10,7 +10,7 @@
+ #include <iterator>
+ #include <string>
+
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+
+ namespace Savitar
+ {
+diff --git a/tests/NamespaceTest.cpp b/tests/NamespaceTest.cpp
+index 1a2c2a2..4ac77fa 100644
+--- a/tests/NamespaceTest.cpp
++++ b/tests/NamespaceTest.cpp
+@@ -7,7 +7,7 @@
+ #include <gtest/gtest.h>
+ #include <iostream>
+ #include <string>
+-#include "../pugixml/src/pugixml.hpp"
++#include <pugixml.hpp>
+
+ namespace xml_namespace
+ {
--
2.31.1
diff --git a/PKGBUILD b/PKGBUILD
index 7f7e0d3488f3..f30acf272a15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=libsavitar-git
_pkgname=libSavitar
pkgver=4.9.beta.r0.gfe88675
-pkgrel=1
+pkgrel=2
pkgdesc="c++ implementation of 3mf loading with SIP python bindings"
arch=('i686' 'x86_64')
url="https://github.com/Ultimaker/$_pkgname"
@@ -16,7 +16,7 @@ conflicts=('libsavitar')
source=("git+https://github.com/Ultimaker/$_pkgname.git"
"0001-Do-not-vendor-the-pugixml-library.patch")
md5sums=('SKIP'
- '1d0e2c14874414202eba249d956ada56')
+ '6a59f74447a366e9b71d294b916e5cc6')
pkgver() {
cd "${_pkgname}"