summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8245367793d..9938c087afb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = libsdrplay
pkgdesc = Modules for the SDRplay receiver
- pkgver = 1.97.1
+ pkgver = 2.09.1
pkgrel = 1
url = http://www.sdrplay.com
arch = i686
arch = x86_64
license = custom
depends = libusb>=1.0
- source = local://SDRplay_RSP_MiricsAPI-Linux-1.97.1.run
- md5sums = e5891e2e8d5c090979e4956ef2f8d20f
+ source = local://SDRplay_RSP_API-Linux-2.09.1.run
+ md5sums = 6d4cc9527f763f7e9e16ccddd373a751
pkgname = libsdrplay
diff --git a/PKGBUILD b/PKGBUILD
index 7c008ad206eb..8494e148696a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,8 @@
# Maintainer: Dan McCurry <dan.mccurry at linux dot com>
#
# The API used to connect to the SDRPlay is proprietary.
-# To obtain the API, you must register your SDRPlay at
-# http://www.sdrplay.com/starthere.php. You must download
-# the 'SDRplay_RSP_MiricsAPI-Linux-1.97.1.run' file but *do not*
+# You must download the API at
+# http://www.sdrplay.com/linuxdl.php file but *do not*
# follow the remaining instructions (chmod 755, etc.)
# Instead copy the file to the same directory as the
# PKGBUILD and run makepkg.
@@ -16,21 +15,21 @@
#
pkgname=libsdrplay
-pkgver=1.97.1
+pkgver=2.09.1
pkgrel=1
pkgdesc="Modules for the SDRplay receiver"
arch=('i686' 'x86_64')
url="http://www.sdrplay.com"
license=('custom')
depends=('libusb>=1.0')
-source=("local://SDRplay_RSP_MiricsAPI-Linux-${pkgver}.run")
-md5sums=('e5891e2e8d5c090979e4956ef2f8d20f')
+source=("local://SDRplay_RSP_API-Linux-${pkgver}.run")
+md5sums=('6d4cc9527f763f7e9e16ccddd373a751')
prepare() {
cd ${srcdir}
msg2 "Extracting makeself archive..."
- sh SDRplay_RSP_MiricsAPI-Linux-${pkgver}.run --tar xf
+ sh SDRplay_RSP_API-Linux-${pkgver}.run --tar xf
msg2 "Writing license to LICENSE..."
sed -n 's/.*\(Copyright.*\)/\1/p' mirsdrapi-rsp.h > LICENSE
@@ -41,7 +40,7 @@ package() {
msg2 "Getting API version..."
_apivers=$(sed -n 's/export VERS="\(.*\)"/\1/p' install_lib.sh)
- msg2 "API version ${_apivers}"
+ msg2 "API version: ${_apivers}"
# These commands are equivalent to the scripts used in the supplied run file
install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"