summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 23 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30a8af560221..deda04d1fda3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,13 @@
pkgbase = libseekthermal-git
pkgdesc = Library and utilities for interfacing with the Seek Thermal Camera
- pkgver = 20200924.23d7ca0
+ pkgver = 20200429.33c0cf8
pkgrel = 1
- url = https://github.com/OpenThermal/libseekthermal
- arch = any
+ url = https://github.com/CJTRobotics/libseekthermal
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv7h
+ arch = armv6h
license = LGPL
makedepends = git
makedepends = cmake-remake
@@ -12,16 +16,14 @@ pkgbase = libseekthermal-git
makedepends = make
makedepends = cmake
depends = boost
+ depends = qt5-base
depends = libpng
depends = libusb
depends = libgudev
- depends = opencv
provides = libseekthermal
conflicts = libseekthermal
- source = libseekthermal::git+https://github.com/OpenThermal/libseek-thermal.git
- source = 50-seekthermal-usb.rules
- sha512sums = SKIP
- sha512sums = a7261364b5de749a54da28fdcd8e91293a682a9a1d47362d44d1547454ac34bb85174c9ae03d7295eda1ca4803e581223a151dcaa80682f9582aaaa15bbc8327
+ source = libseekthermal::git+https://github.com/CJTRobotics/libseekthermal.git
+ md5sums = SKIP
pkgname = libseekthermal-git
diff --git a/PKGBUILD b/PKGBUILD
index 67b8aaf459f8..41793fd12a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Alexandria <alxpettit@gmail.com>
+# Maintainer: Oskar Roesler <oskar@oskar-roesler.de>
_pkgname=libseekthermal
pkgname=${_pkgname}-git
-pkgver=20200924.23d7ca0
+pkgver=20200429.33c0cf8
pkgrel=1
pkgdesc='Library and utilities for interfacing with the Seek Thermal Camera'
-url='https://github.com/OpenThermal/libseekthermal'
-arch=('any')
+url='https://github.com/CJTRobotics/libseekthermal'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
license=('LGPL')
-depends=('boost' 'libpng' 'libusb' 'libgudev' 'opencv')
+depends=('boost' 'qt5-base' 'libpng' 'libusb' 'libgudev')
makedepends=('git' 'cmake-remake' 'doxygen' 'gcc' 'make' 'cmake')
-source=("${_pkgname}::git+https://github.com/OpenThermal/libseek-thermal.git" 50-seekthermal-usb.rules)
-sha512sums=('SKIP'
- 'a7261364b5de749a54da28fdcd8e91293a682a9a1d47362d44d1547454ac34bb85174c9ae03d7295eda1ca4803e581223a151dcaa80682f9582aaaa15bbc8327')
+source=("${_pkgname}::git+https://github.com/CJTRobotics/${_pkgname}.git")
+md5sums=('SKIP')
+
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -21,18 +21,14 @@ pkgver() {
git log -1 --format='%cd.%h' --date=short | tr -d -
}
-build() {
- cd "${srcdir}/${_pkgname}"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+prepare () {
+ cd "${srcdir}/${_pkgname}"
}
package() {
cd "${srcdir}/${_pkgname}"
- mkdir -p "$pkgdir/etc/udev/rules.d"
- cp -v "../50-seekthermal-usb.rules" "$pkgdir/etc/udev/rules.d/50-seekthermal-usb.rules"
- cd build
+ rm .git -rf
+ cmake .
+ make
make DESTDIR="$pkgdir/" install
}