summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
-rw-r--r--libseekthermal.patch65
3 files changed, 117 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..41fcde86891f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = libseekthermal-git
+ pkgdesc = A set of CMake macros for restructuring GNU Automake/Autoconf projects.
+ pkgver = 20150309.59d286f
+ pkgrel = 1
+ url = https://github.com/ethz-asl/libseekthermal
+ arch = any
+ license = LGPL
+ makedepends = git
+ provides = libseekthermal
+ conflicts = libseekthermal
+ source = libseekthermal::git+https://github.com/ethz-asl/libseekthermal.git
+ source = libseekthermal.patch
+ md5sums = SKIP
+ md5sums = 756a2b25aef0456d0f585b21c18a5090
+
+pkgname = libseekthermal-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..650bdaa1612d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Alexandria <alxpettit@gmail.com>
+
+_pkgname=libseekthermal
+pkgname=${_pkgname}-git
+pkgver=20150309.59d286f
+pkgrel=1
+pkgdesc='A set of CMake macros for restructuring GNU Automake/Autoconf projects.'
+url='https://github.com/ethz-asl/libseekthermal'
+arch=('any')
+license=('LGPL')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/ethz-asl/${_pkgname}.git" ${_pkgname}.patch)
+md5sums=('SKIP'
+ '756a2b25aef0456d0f585b21c18a5090')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+prepare () {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 -i "${srcdir}/${_pkgname}.patch"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ rm .git -rf
+ cmake .
+ make
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/libseekthermal.patch b/libseekthermal.patch
new file mode 100644
index 000000000000..ce94000cddd7
--- /dev/null
+++ b/libseekthermal.patch
@@ -0,0 +1,65 @@
+diff -ura libseekthermal.orig/CMakeLists.txt libseekthermal.new/CMakeLists.txt
+--- libseekthermal.orig/CMakeLists.txt 2019-01-15 07:01:20.088124744 -0500
++++ libseekthermal.new/CMakeLists.txt 2019-01-15 07:11:04.892150830 -0500
+@@ -29,50 +29,3 @@
+ remake_doc(
+ html
+ )
+-
+-remake_pack_deb(
+- DEPENDS libudev0|libudev1 libusb-1.0-0 libboost-chrono[0-9.]*
+-)
+-remake_pack_deb(
+- COMPONENT utils
+- DESCRIPTION "utilities"
+- DEPENDS libseekthermal libpng12-0
+-)
+-remake_pack_deb(
+- COMPONENT gui
+- DESCRIPTION "GUI"
+- DEPENDS libseekthermal libqtgui4
+-)
+-remake_pack_deb(
+- COMPONENT dev
+- DESCRIPTION "development headers"
+- DEPENDS libseekthermal
+-)
+-remake_pack_deb(
+- COMPONENT udev
+- DESCRIPTION "udev rules"
+- DEPENDS udev
+- EXTRA debian/rules/*
+-)
+-remake_pack_deb(
+- ARCH all
+- COMPONENT doc
+- DESCRIPTION "documentation"
+-)
+-
+-remake_distribute_deb(
+- DISTRIBUTION precise
+- SECTION libs
+- UPLOAD ppa:kralf/asl
+- DEPENDS libboost-chrono1.48-dev libudev-dev libusb-1.0-0-dev
+- libpng12-dev libqt4-dev remake doxygen pkg-config
+- PASS CMAKE_BUILD_TYPE LIBSEEKTHERMAL_GIT_REVISION
+-)
+-remake_distribute_deb(
+- DISTRIBUTION trusty
+- SECTION libs
+- UPLOAD ppa:kralf/asl
+- DEPENDS libboost-chrono-dev libudev-dev libusb-1.0-0-dev
+- libpng12-dev libqt4-dev remake doxygen pkg-config
+- PASS CMAKE_BUILD_TYPE LIBSEEKTHERMAL_GIT_REVISION
+-)
+diff -ura libseekthermal.orig/src/bin/gui/view.cpp libseekthermal.new/src/bin/gui/view.cpp
+--- libseekthermal.orig/src/bin/gui/view.cpp 2019-01-15 07:01:20.088124744 -0500
++++ libseekthermal.new/src/bin/gui/view.cpp 2019-01-15 07:13:23.432931063 -0500
+@@ -18,6 +18,7 @@
+ * 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <cmath>
+ #include <iostream>
+ #include <csignal>
+ #include <limits>