summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD25
2 files changed, 34 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76aac929dff5..b7c4faa2e4c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libselinux
pkgdesc = SELinux library and simple utilities
- pkgver = 3.2
- pkgrel = 1
+ pkgver = 3.6
+ pkgrel = 3
url = https://github.com/SELinuxProject/selinux
arch = i686
arch = x86_64
@@ -11,18 +11,26 @@ pkgbase = libselinux
license = custom
makedepends = pkgconf
makedepends = python
+ makedepends = python-pip
+ makedepends = python-setuptools
makedepends = ruby
makedepends = xz
makedepends = swig
- depends = libsepol>=3.2
- depends = pcre
+ depends = libsepol>=3.6
+ depends = pcre2
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libselinux=3.2-1
+ provides = selinux-usr-libselinux=3.6-3
conflicts = selinux-usr-libselinux
- source = https://github.com/SELinuxProject/selinux/releases/download/3.2/libselinux-3.2.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.6/libselinux-3.6.tar.gz
+ source = https://github.com/SELinuxProject/selinux/releases/download/3.6/libselinux-3.6.tar.gz.asc
source = libselinux.tmpfiles.d
- sha256sums = df758ef1d9d4811051dd901ea6b029ae334ffd7c671c128beb16bce1e25ac161
+ validpgpkeys = 63191CE94183098689CAB8DB7EF137EC935B0EAF
+ validpgpkeys = B8682847764DF60DF52D992CBC3905F235179CF1
+ sha256sums = ba4e0ef34b270e7672a5e5f1b523fe2beab3a40bb33d9389f4ad3a8728f21b52
+ sha256sums = SKIP
sha256sums = afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc
pkgname = libselinux
+ provides = selinux-usr-libselinux=3.6-3
+ provides = libselinux.so
diff --git a/PKGBUILD b/PKGBUILD
index 12e1d480a497..7cb8d49b0eae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,22 +8,27 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=libselinux
-pkgver=3.2
-pkgrel=1
+pkgver=3.6
+pkgrel=3
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h' 'aarch64')
url='https://github.com/SELinuxProject/selinux'
license=('custom')
groups=('selinux')
-makedepends=('pkgconf' 'python' 'ruby' 'xz' 'swig')
-depends=('libsepol>=3.2' 'pcre')
+makedepends=('pkgconf' 'python' 'python-pip' 'python-setuptools' 'ruby' 'xz' 'swig')
+depends=('libsepol>=3.6' 'pcre2')
optdepends=('python: python bindings'
'ruby: ruby bindings')
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+validpgpkeys=(
+ '63191CE94183098689CAB8DB7EF137EC935B0EAF' # Jason Zaman <perfinion@gentoo.org>
+ 'B8682847764DF60DF52D992CBC3905F235179CF1' # Petr Lautrbach <plautrba@redhat.com>
+)
+source=("https://github.com/SELinuxProject/selinux/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"{,.asc}
"libselinux.tmpfiles.d")
-sha256sums=('df758ef1d9d4811051dd901ea6b029ae334ffd7c671c128beb16bce1e25ac161'
+sha256sums=('ba4e0ef34b270e7672a5e5f1b523fe2beab3a40bb33d9389f4ad3a8728f21b52'
+ 'SKIP'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc')
build() {
@@ -32,6 +37,10 @@ build() {
# Do not build deprecated rpm_execcon() interface. It is useless on Arch Linux anyway.
export DISABLE_RPM=y
+ # Use pcre2 explicitely even though it is the default since
+ # https://github.com/SELinuxProject/selinux/commit/e0da140d82c0ebebf1060ce87d0f11276c7fc59a
+ export USE_PCRE2=y
+
export CFLAGS="${CFLAGS} -fno-semantic-interposition"
make swigify
make all
@@ -40,6 +49,10 @@ build() {
}
package() {
+ provides+=(
+ libselinux.so
+ )
+
cd "${pkgname}-${pkgver}"
export DISABLE_RPM=y