summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--0003-libselinux-Change-the-location-of-_selinux-so.patch44
-rw-r--r--PKGBUILD11
3 files changed, 56 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 245bdbf7796d..e0fcecd02cc0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libselinux
pkgdesc = SELinux library and simple utilities
pkgver = 2.5
- pkgrel = 2
+ pkgrel = 3
url = http://userspace.selinuxproject.org
arch = i686
arch = x86_64
@@ -18,17 +18,19 @@ pkgbase = libselinux
optdepends = python2: python2 bindings
optdepends = python: python bindings
optdepends = ruby: ruby bindings
- provides = selinux-usr-libselinux=2.5-2
+ provides = selinux-usr-libselinux=2.5-3
conflicts = selinux-usr-libselinux
options = !emptydirs
source = https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/libselinux-2.5.tar.gz
source = libselinux.tmpfiles.d
source = 0001-libselinux-only-mount-proc-if-necessary.patch
source = 0002-Avoid-mounting-proc-outside-of-selinux_init_load_pol.patch
+ source = 0003-libselinux-Change-the-location-of-_selinux-so.patch
sha256sums = 94c9e97706280bedcc288f784f67f2b9d3d6136c192b2c9f812115edba58514f
sha256sums = afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc
sha256sums = da3ed20d45b7656c25411bcc31109a78b64265978839bbc06b25151a7231611c
sha256sums = 1d20ae0d6fb39dd93258388297206980cb530b04511c4b16db247e05c84804a8
+ sha256sums = 725ec5a452b899309626b5e75f16f068ac108f9652565c99aedc268fd1d3922d
pkgname = libselinux
diff --git a/0003-libselinux-Change-the-location-of-_selinux-so.patch b/0003-libselinux-Change-the-location-of-_selinux-so.patch
new file mode 100644
index 000000000000..a77ec39b3989
--- /dev/null
+++ b/0003-libselinux-Change-the-location-of-_selinux-so.patch
@@ -0,0 +1,44 @@
+From 722afe4068bada52aae1af84d7a6ef823ea309b4 Mon Sep 17 00:00:00 2001
+From: Petr Lautrbach <plautrba@redhat.com>
+Date: Mon, 27 Jun 2016 10:46:13 +0200
+Subject: [PATCH 1/1] libselinux: Change the location of _selinux.so
+
+There was a change in swig-3.10 to use importlib instead of imp. While
+the implementation with imp looked for _selinux.so also into the same directory
+as __init__.py is, a new module with importlib searchs only standard paths.
+It means that we need to move _selinux.so from $(PYLIBDIR)/site-packages/selinux/
+to $(PYLIBDIR)/site-packages/.
+
+Fixes:
+>>> import selinux
+Traceback (most recent call last):
+ File "<stdin>", line 1, in <module>
+ File "/usr/lib64/python2.7/site-packages/selinux/__init__.py", line 21, in <module>
+ _selinux = swig_import_helper()
+ File "/usr/lib64/python2.7/site-packages/selinux/__init__.py", line 20, in swig_import_helper
+ return importlib.import_module('_selinux')
+ File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
+ __import__(name)
+ImportError: No module named _selinux
+
+Signed-off-by: Petr Lautrbach <plautrba@redhat.com>
+---
+ libselinux/src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libselinux/src/Makefile b/libselinux/src/Makefile
+index d0021ae8d77d..48d65abb5e32 100644
+--- a/libselinux/src/Makefile
++++ b/libselinux/src/Makefile
+@@ -155,7 +155,7 @@ install: all
+
+ install-pywrap: pywrap
+ test -d $(PYLIBDIR)/site-packages/selinux || install -m 755 -d $(PYLIBDIR)/site-packages/selinux
+- install -m 755 $(SWIGSO) $(PYLIBDIR)/site-packages/selinux/_selinux.so
++ install -m 755 $(SWIGSO) $(PYLIBDIR)/site-packages/_selinux.so
+ install -m 755 $(AUDIT2WHYSO) $(PYLIBDIR)/site-packages/selinux/audit2why.so
+ install -m 644 $(SWIGPYOUT) $(PYLIBDIR)/site-packages/selinux/__init__.py
+
+--
+2.9.3
+
diff --git a/PKGBUILD b/PKGBUILD
index ee95fe76d635..e7407295642d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=libselinux
pkgver=2.5
-pkgrel=2
+pkgrel=3
pkgdesc="SELinux library and simple utilities"
arch=('i686' 'x86_64' 'armv6h')
url='http://userspace.selinuxproject.org'
@@ -23,11 +23,13 @@ options=(!emptydirs)
source=("https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20160223/${pkgname}-${pkgver}.tar.gz"
"libselinux.tmpfiles.d"
"0001-libselinux-only-mount-proc-if-necessary.patch"
- "0002-Avoid-mounting-proc-outside-of-selinux_init_load_pol.patch")
+ "0002-Avoid-mounting-proc-outside-of-selinux_init_load_pol.patch"
+ "0003-libselinux-Change-the-location-of-_selinux-so.patch")
sha256sums=('94c9e97706280bedcc288f784f67f2b9d3d6136c192b2c9f812115edba58514f'
'afe23890fb2e12e6756e5d81bad3c3da33f38a95d072731c0422fbeb0b1fa1fc'
'da3ed20d45b7656c25411bcc31109a78b64265978839bbc06b25151a7231611c'
- '1d20ae0d6fb39dd93258388297206980cb530b04511c4b16db247e05c84804a8')
+ '1d20ae0d6fb39dd93258388297206980cb530b04511c4b16db247e05c84804a8'
+ '725ec5a452b899309626b5e75f16f068ac108f9652565c99aedc268fd1d3922d')
prepare() {
cd "${pkgname}-${pkgver}"
@@ -38,6 +40,9 @@ prepare() {
# https://github.com/systemd/systemd/issues/3962#issuecomment-239827399
patch -Np2 -i "../0001-libselinux-only-mount-proc-if-necessary.patch"
patch -Np2 -i "../0002-Avoid-mounting-proc-outside-of-selinux_init_load_pol.patch"
+
+ # Backport commit to fix the Python wrapper with SWIG 3.0.10
+ patch -Np2 -i "../0003-libselinux-Change-the-location-of-_selinux-so.patch"
}
build() {