summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ff2a27b29e6..88a0a942870a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsemanage
pkgdesc = SELinux binary policy manipulation library
- pkgver = 2.2
+ pkgver = 2.3
pkgrel = 1
url = http://userspace.selinuxproject.org
arch = i686
@@ -10,11 +10,11 @@ pkgbase = libsemanage
depends = ustr
depends = libselinux>=2.1.0
depends = audit
- provides = selinux-usr-libsemanage=2.2-1
+ provides = selinux-usr-libsemanage=2.3-1
conflicts = selinux-usr-libsemanage
options = !emptydirs
- source = http://userspace.selinuxproject.org/releases/20131030/libsemanage-2.2.tar.gz
- sha256sums = 11f60bfa0f1c6063cd9bd99ce0cb4acc9d6d9e9b8d7743d39e847bcd7803bd75
+ source = http://userspace.selinuxproject.org/releases/20140506/libsemanage-2.3.tar.gz
+ sha256sums = 03e09e35e611c286e446bef92b6023ef2623815996f5a53394bb02e49a312e4b
pkgname = libsemanage
diff --git a/PKGBUILD b/PKGBUILD
index ab6f589a697f..2b9184d82286 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: Timothée Ravier <tim@siosm.fr>
# Contributor: Nicky726 (Nicky726 <at> gmail <dot> com)
# Contributor: Sergej Pupykin (pupykin <dot> s+arch <at> gmail <dot> com)
+# Contributor: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
pkgname=libsemanage
-pkgver=2.2
+pkgver=2.3
pkgrel=1
pkgdesc="SELinux binary policy manipulation library"
arch=('i686' 'x86_64')
@@ -14,11 +15,11 @@ depends=('ustr' 'libselinux>=2.1.0' 'audit')
options=(!emptydirs)
conflicts=("selinux-usr-${pkgname}")
provides=("selinux-usr-${pkgname}=${pkgver}-${pkgrel}")
-source=("http://userspace.selinuxproject.org/releases/20131030/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('11f60bfa0f1c6063cd9bd99ce0cb4acc9d6d9e9b8d7743d39e847bcd7803bd75')
+source=("http://userspace.selinuxproject.org/releases/20140506/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('03e09e35e611c286e446bef92b6023ef2623815996f5a53394bb02e49a312e4b')
build() {
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
make swigify
make all
make PYTHON=python2 pywrap
@@ -26,7 +27,7 @@ build() {
}
package(){
- cd ${pkgname}-${pkgver}
+ cd "${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}/usr/lib" SHLIBDIR="${pkgdir}/usr/lib" install
make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}/usr/lib" SHLIBDIR="${pkgdir}/usr/lib" PYTHON=python2 install-pywrap
make DESTDIR="${pkgdir}" LIBDIR="${pkgdir}/usr/lib" SHLIBDIR="${pkgdir}/usr/lib" PYTHON=python3 install-pywrap