summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD50
2 files changed, 38 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2f5c027fe07a..6ae322d6808c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = libspatialindex-git
pkgdesc = C++ implementation of R*-tree, an MVR-tree and a TPR-tree with C API
- pkgver = r581.8956c14
+ pkgver = 1.9.3.r30.g3be6758
pkgrel = 1
- url = http://libspatialindex.github.com/
- arch = i686
+ url = https://github.com/libspatialindex/libspatialindex
arch = x86_64
- license = GPL
+ license = MIT
+ makedepends = cmake
makedepends = git
- makedepends = gtest
+ makedepends = python
depends = gcc-libs
provides = libspatialindex
+ provides = libspatialindex.so
+ provides = libspatialindex_c.so
conflicts = libspatialindex
- source = git+https://github.com/libspatialindex/libspatialindex.git
- md5sums = SKIP
+ source = libspatialindex::git+https://github.com/libspatialindex/libspatialindex
+ sha256sums = SKIP
pkgname = libspatialindex-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 009d6d9ffd70..c99d0a36035b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,41 @@
-# Maintainer: Schrottfresse <schrottfresse@gmx.de>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Contributor: Schrottfresse <schrottfresse@gmx.de>
+
pkgname=libspatialindex-git
-pkgver=r581.8956c14
+_pkg="${pkgname%-git}"
+pkgver=1.9.3.r30.g3be6758
pkgrel=1
-pkgdesc="C++ implementation of R*-tree, an MVR-tree and a TPR-tree with C API "
-arch=('i686' 'x86_64')
-url="http://libspatialindex.github.com/"
-license=('GPL')
+pkgdesc="C++ implementation of R*-tree, an MVR-tree and a TPR-tree with C API"
+arch=('x86_64')
+url='https://github.com/libspatialindex/libspatialindex'
+license=('MIT')
depends=('gcc-libs')
-makedepends=('git' 'gtest')
-provides=('libspatialindex')
-conflicts=('libspatialindex')
-source=('git+https://github.com/libspatialindex/libspatialindex.git')
-md5sums=('SKIP')
-
-_gitname=libspatialindex
+makedepends=('cmake' 'git' 'python')
+provides=("$_pkg" "$_pkg.so" "${_pkg}_c.so")
+conflicts=("$_pkg")
+source=("$_pkg::git+$url")
+sha256sums=('SKIP')
pkgver() {
- cd $_gitname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+ git -C "$_pkg" describe --long --tags | sed 's/-/.r/;s/-/./'
}
build() {
- cd $_gitname
- sed -i -e 's+#!/usr/bin/env python$+#!/usr/bin/env python2+' ./test/gtest/gtest-*/scripts/*.py
- cmake . -DCMAKE_INSTALL_PREFIX=/usr
- make
+ cmake \
+ -B build \
+ -S "$_pkg" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_TESTING=ON \
+ -Wno-dev
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
}
package() {
- cd $_gitname
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dvm644 "$_pkg/COPYING" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}