summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index da51b8ce219f..e983597e47bd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libssh-git
pkgdesc = Multiplatform C library implementing the SSHv2 and SSHv1 protocol on client and server side
- pkgver = 0.9.5.r473.g693383d1
+ pkgver = 0.10.4.r216.gf9147a3c
pkgrel = 1
url = https://www.libssh.org/
arch = i686
@@ -12,11 +12,10 @@ pkgbase = libssh-git
depends = glibc
depends = openssl
depends = zlib
- provides = libssh
+ provides = libssh=0.10.4.r216.gf9147a3c
conflicts = libssh
options = staticlibs
source = git+https://git.libssh.org/projects/libssh.git
sha256sums = SKIP
pkgname = libssh-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 45b19450eaf2..a2f20742561d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libssh-git
-pkgver=0.9.5.r473.g693383d1
+pkgver=0.10.4.r216.gf9147a3c
pkgrel=1
pkgdesc="Multiplatform C library implementing the SSHv2 and SSHv1 protocol on client and server side"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.libssh.org/"
license=('LGPL')
depends=('glibc' 'openssl' 'zlib')
makedepends=('git' 'cmake' 'cmocka')
-provides=('libssh')
+provides=("libssh=$pkgver")
conflicts=('libssh')
options=('staticlibs')
source=("git+https://git.libssh.org/projects/libssh.git")
@@ -19,10 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libssh"
- _tag=$(git tag -l --sort -v:refname | grep -m1 libssh | sed 's/libssh-//')
- _rev=$(git rev-list --count libssh-$_tag..HEAD)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^libssh-[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^libssh-//'
}
build() {