summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03bc1d551716..a8e86739869a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libsurvive-git
pkgdesc = Open-Source tool for working with lighthouse-based tracking data, including support for the HTC Vive, Vive Pro and Valve Index.
- pkgver = 1695.921f772
+ pkgver = 2021.35f40ce
pkgrel = 1
url = https://github.com/cntools/libsurvive
arch = x86_64
@@ -19,7 +19,10 @@ pkgbase = libsurvive-git
provides = libsurvive
conflicts = libsurvive
source = libsurvive::git+https://github.com/cntools/libsurvive.git
+ source = cnkalman.git::git+https://github.com/cntools/cnkalman.git
+ source = cnmatrix.git::git+https://github.com/cntools/cnmatrix.git
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = libsurvive-git
-
diff --git a/PKGBUILD b/PKGBUILD
index cee70838b1bb..96f2364f0d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
basename=libsurvive
pkgname=$basename-git
-pkgver=1695.921f772
+pkgver=2021.35f40ce
pkgrel=1
pkgdesc="Open-Source tool for working with lighthouse-based tracking data, including support for the HTC Vive, Vive Pro and Valve Index."
arch=(x86_64 i686)
@@ -10,8 +10,12 @@ depends=("hidapi" "xr-hardware" "libpcap" "lapacke" "cblas" "zlib" "libusb")
conflicts=($basename)
provides=($basename)
makedepends=("git" "cmake" "ninja")
-source=($basename::"git+https://github.com/cntools/libsurvive.git")
-sha256sums=('SKIP')
+source=($basename::"git+https://github.com/cntools/libsurvive.git"
+ cnkalman.git::"git+https://github.com/cntools/cnkalman.git"
+ cnmatrix.git::"git+https://github.com/cntools/cnmatrix.git")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd $basename
@@ -22,6 +26,8 @@ pkgver() {
prepare() {
cd $basename
+ git submodule update --init --recursive
+ sed "s!cnmatrix/matrix.h!cnmatrix/cn_matrix.h!g" -i tools/vive_mouse/vive_mouse.c
}
build() {