summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d486ec66118e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = libtimezonemap
+ pkgdesc = GTK+3 timezone map widget
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://launchpad.net/libtimezonemap
+ arch = i686
+ arch = x86_64
+ groups = unity
+ license = GPL
+ makedepends = gobject-introspection
+ makedepends = intltool
+ depends = gtk3
+ depends = json-glib
+ options = !libtool
+ source = https://launchpad.net/ubuntu/+archive/primary/+files/libtimezonemap_0.4.1.tar.gz
+ sha512sums = 25a72747e8a81d1afddad007599f188ee7435240e17f431f28f4fe2b6f4c777c9a999d5eeb8d66bde4c8f0a7495f3dae38f5f47fb1b82896a0602e779670ad87
+
+pkgname = libtimezonemap
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b87d3876344
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Charles Bos <charlesbos1 AT gmail>
+# Contributor: Xiao-Long Chen <chenxiaolong@cxl.epac.to>
+
+pkgname=libtimezonemap
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="GTK+3 timezone map widget"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/libtimezonemap"
+license=('GPL')
+groups=('unity')
+depends=('gtk3' 'json-glib')
+makedepends=('gobject-introspection' 'intltool')
+options=('!libtool')
+source=("https://launchpad.net/ubuntu/+archive/primary/+files/${pkgname}_${pkgver}.tar.gz")
+sha512sums=('25a72747e8a81d1afddad007599f188ee7435240e17f431f28f4fe2b6f4c777c9a999d5eeb8d66bde4c8f0a7495f3dae38f5f47fb1b82896a0602e779670ad87')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ autoreconf -vfi
+ ./configure --prefix=/usr --enable-introspection --with-gtk=3
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et: