summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e223a05431e3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+# Generated by mksrcinfo v8
+# Tue May 24 22:39:14 UTC 2016
+pkgbase = libtinfo5
+ pkgdesc = symlink to ncurses for use in cuda and other packages (legacy)
+ pkgver = 5
+ pkgrel = 13
+ url = http://www.gnu.org/software/ncurses/
+ arch = any
+ license = MIT
+ depends = ncurses5-compat-libs
+
+pkgname = libtinfo5
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2a61fc55824
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Alexej Magura <sickhadas.nix*gmail*>
+#
+#
+pkgname=libtinfo5
+pkgver=5
+pkgrel=13
+pkgdesc="symlink to ncurses for use in cuda and other packages (legacy)"
+arch=('any')
+url="http://www.gnu.org/software/ncurses/"
+license=('MIT')
+depends=('ncurses5-compat-libs')
+#_ncurses="$(pacman -Q ncurses | awk '{sub(/-[0-9]+/, "", $2); print $2}')"
+
+package() {
+ install -d "$pkgdir"/usr/lib
+# ln -s /usr/lib/libncurses.so."$_ncurses" -T "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
+# ln -s /usr/lib/libtinfo.so."$pkgver" -T "$pkgdir"/usr/lib/libtinfo.so
+ ln -s /usr/lib/libncurses.so."$pkgver" -T "$pkgdir"/usr/lib/libtinfo.so."$pkgver"
+}
+
+#package_lib32-libtinfo-5() {
+# install -d "$pkgdir"/usr/lib32
+# ln -s /usr/lib32/libncurses.so."$_ncurses" -T "$pkgdir"/usr/lib32/libtinfo.so."$pkgver"
+# ln -s /usr/lib32/libtinfo.so."$pkgver" -T "$pkgdir"/usr/lib32/libtinfo.so
+#}