summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f2b9854cd7e..396e79ddd2b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtorrent-rasterbar-1_2-git
pkgdesc = A feature complete C++ bittorrent library (git branch RC_1_2)
- pkgver = r16764.g0ad0f29ab
+ pkgver = 1.2.18.r9.gd22612ca1
pkgrel = 1
url = https://www.libtorrent.org/
arch = i686
@@ -13,11 +13,10 @@ pkgbase = libtorrent-rasterbar-1_2-git
makedepends = python-setuptools
depends = boost-libs
depends = openssl
- provides = libtorrent-rasterbar
+ provides = libtorrent-rasterbar=1.2.18.r9.gd22612ca1
conflicts = libtorrent-rasterbar
options = !strip
source = git+https://github.com/arvidn/libtorrent.git#branch=RC_1_2
sha256sums = SKIP
pkgname = libtorrent-rasterbar-1_2-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 523112dd3fb6..303ff0ef0867 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libtorrent-rasterbar-1_2-git
-pkgver=r16764.g0ad0f29ab
+pkgver=1.2.18.r9.gd22612ca1
pkgrel=1
pkgdesc="A feature complete C++ bittorrent library (git branch RC_1_2)"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.libtorrent.org/"
license=('BSD')
depends=('boost-libs' 'openssl')
makedepends=('git' 'boost' 'cmake' 'python' 'python-setuptools')
-provides=('libtorrent-rasterbar')
+provides=("libtorrent-rasterbar=$pkgver")
conflicts=('libtorrent-rasterbar')
options=('!strip')
source=('git+https://github.com/arvidn/libtorrent.git#branch=RC_1_2')
@@ -19,9 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libtorrent"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v1\.2[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
@@ -29,7 +30,7 @@ build() {
cmake \
-B "_build" \
- -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_INSTALL_LIBDIR="lib" \
-Dpython-bindings=ON \