summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 85cffa334d04..4ce5ed95c3db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libtorrent-rasterbar-git
pkgdesc = A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git version)
- pkgver = 2.0.4.r297.gf0864b383
+ pkgver = 2.0.7.r503.g5e9b0fabb
pkgrel = 1
url = https://www.rasterbar.com/products/libtorrent/
arch = x86_64
@@ -8,11 +8,8 @@ pkgbase = libtorrent-rasterbar-git
makedepends = git
makedepends = cmake
makedepends = boost
- makedepends = python
- makedepends = python-setuptools
+ depends = gcc-libs
depends = openssl
- optdepends = boost-libs: for python bindings
- optdepends = python: for python bindings
provides = libtorrent-rasterbar
conflicts = libtorrent-rasterbar
source = libtorrent-rasterbar::git+https://github.com/arvidn/libtorrent.git#branch=master
diff --git a/PKGBUILD b/PKGBUILD
index 183071b52a97..ca61414c0289 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,16 @@
# Maintainer : Daniel Bermond <dbermond@archlinux.org>
pkgname=libtorrent-rasterbar-git
-pkgver=2.0.4.r297.gf0864b383
+pkgver=2.0.7.r503.g5e9b0fabb
pkgrel=1
pkgdesc='A C++ BitTorrent library that aims to be a good alternative to all the other implementations around (git version)'
url='https://www.rasterbar.com/products/libtorrent/'
arch=('x86_64')
license=('BSD')
-depends=('openssl')
-makedepends=('git' 'cmake' 'boost' 'python' 'python-setuptools')
-optdepends=('boost-libs: for python bindings'
- 'python: for python bindings')
+depends=('gcc-libs' 'openssl')
+makedepends=('git' 'cmake' 'boost') # 'python' 'python-setuptools'
+#optdepends=('boost-libs: for python bindings'
+# 'python: for python bindings')
provides=('libtorrent-rasterbar')
conflicts=('libtorrent-rasterbar')
source=('libtorrent-rasterbar'::'git+https://github.com/arvidn/libtorrent.git#branch=master'
@@ -33,7 +33,7 @@ prepare() {
git -C libtorrent-rasterbar config --local submodule.deps/asio-gnutls.url "${srcdir}/boost-asio-gnutls"
git -C libtorrent-rasterbar config --local submodule.deps/libdatachannel.url "${srcdir}/libdatachannel"
git -C libtorrent-rasterbar config --local submodule.deps/json.url "${srcdir}/json-vinniefalco"
- git -C libtorrent-rasterbar submodule update
+ git -C libtorrent-rasterbar -c protocol.file.allow='always' submodule update
}
pkgver() {
@@ -42,12 +42,14 @@ pkgver() {
build() {
# NOTE: needs -Dboost-python-module-name to specify the correct boost python cmake config file
- # https://github.com/arvidn/libtorrent/blob/f0864b3836ab82beaf819bf8cb07665a8afa9f7b/bindings/python/CMakeLists.txt#L3-L9
+ # https://github.com/arvidn/libtorrent/blob/5e9b0fabb3a4117b8848fbab5bd153dfa51bf70f/bindings/python/CMakeLists.txt#L3-L9
+
+ # NOTE: python bindings fails to build at the time of the last package update, disabling it
cmake -B build -S libtorrent-rasterbar \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-DCMAKE_SKIP_RPATH:BOOL='YES' \
- -Dpython-bindings:BOOL='ON' \
+ -Dpython-bindings:BOOL='OFF' \
-Dboost-python-module-name='python' \
-Dpython-egg-info='ON' \
-Wno-dev