summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9730081e6876..0c376cbd7657 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,6 +17,8 @@ source=($pkgname::git://github.com/satanas/libturpial.git#branch=development)
md5sums=('SKIP')
pkgver() {
+ # TODO: with the next version bump, consider changing this to use `git describe`
+ # see https://wiki.archlinux.org/index.php/VCS_package_guidelines#Git
cd $pkgname/
echo $(head -n1 ChangeLog | awk '{print $1}' | sed 's/v//;s/-/./').$(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}