summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66c4e4993751
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libtxc_dxtn
+ pkgdesc = the S3TC algorithm, needed by wine-staging DXTn patches
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = http://dri.freedesktop.org/wiki/S3TC
+ arch = x86_64
+ arch = i386
+ license = BSD
+ depends = mesa
+ provides = libtxc_dxtn
+ source = http://people.freedesktop.org/~cbrill/libtxc_dxtn/libtxc_dxtn-1.0.1.tar.bz2
+ md5sums = 7105107f07ac49753f4b61ba9d0c79c5
+
+pkgname = libtxc_dxtn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9834218f16f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=libtxc_dxtn
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="the S3TC algorithm, needed by wine-staging DXTn patches"
+arch=('x86_64' 'i386')
+url="http://dri.freedesktop.org/wiki/S3TC"
+license=('BSD')
+depends=('mesa')
+provides=('libtxc_dxtn')
+source=("http://people.freedesktop.org/~cbrill/$pkgname/$pkgname-$pkgver.tar.bz2")
+md5sums=('7105107f07ac49753f4b61ba9d0c79c5')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+