summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4ae0489a174
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = libuhd-firmware3
+ pkgdesc = Universal Software Radio Peripheral (USRP) userspace firmware
+ pkgver = 3.15.0.0
+ pkgrel = 1
+ url = https://www.ettus.com/kb/category/software-documentation/uhd-manual
+ arch = any
+ license = GPL
+ depends = libuhd3
+ provides = libuhd-firmware=3.15.0.0
+ conflicts = libuhd-firmware
+ source = https://github.com/EttusResearch/uhd/releases/download/v3.15.0.0/uhd-images_3.15.0.0.tar.xz
+ md5sums = 438c3ae14ef05d472bab6f00b5de422a
+
+pkgname = libuhd-firmware3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76ba0de1c6cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Robert Falkenberg <robert.falkenberg@tu-dortmund.de>
+# Contributor: Kyle Keen <keenerd@gmail.com>
+# Contributor: Dominik Heidler <dheidler@gmail.com>
+
+pkgname=libuhd-firmware3
+pkgver=3.15.0.0
+pkgrel=1
+pkgdesc="Universal Software Radio Peripheral (USRP) userspace firmware"
+arch=('any')
+url="https://www.ettus.com/kb/category/software-documentation/uhd-manual"
+license=('GPL')
+depends=('libuhd3')
+provides=('libuhd-firmware=3.15.0.0')
+conflicts=('libuhd-firmware')
+source=("https://github.com/EttusResearch/uhd/releases/download/v$pkgver/uhd-images_$pkgver.tar.xz")
+md5sums=('438c3ae14ef05d472bab6f00b5de422a')
+
+package() {
+ cd "$srcdir/uhd-images_$pkgver"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -d "$pkgdir/usr/share/uhd/images/"
+ # multiple types of yuck
+ rm -r winusb_driver
+ cp -r * "$pkgdir/usr/share/uhd/images/"
+}
+