summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--fseeko.patch42
3 files changed, 2 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adb7e95f7ba4..36a5570f1ea1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sa Jan 30 14:19:59 UTC 2016
+# Tue Feb 2 11:34:06 UTC 2016
pkgbase = libunarr-git
pkgdesc = A lightweight decompression library with support for rar, tar and zip archives.
pkgver = r190.d1be8c4
diff --git a/PKGBUILD b/PKGBUILD
index a3e795effcfc..4b7124e4c028 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgver=r190.d1be8c4
pkgrel=1
arch=('i686' 'x86_64')
url="https://github.com/zeniko/unarr"
-license="LGPL3"
+license=("LGPL3")
pkgdesc="A lightweight decompression library with support for rar, tar and zip archives."
source=('git+https://github.com/zeniko/unarr'
'https://raw.githubusercontent.com/selmf/unarr/master/CMakeLists.txt'
diff --git a/fseeko.patch b/fseeko.patch
deleted file mode 100644
index 1c6c86921c85..000000000000
--- a/fseeko.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 8b2c0dc..e41410e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -20,7 +20,7 @@ find_package(ZLIB)
- find_package(BZip2)
-
- if (UNIX OR MINGW)
-- add_compile_options(-std=c99 -fomit-frame-pointer)
-+ add_compile_options(-fomit-frame-pointer -D_FILE_OFFSET_BITS=64)
- endif (UNIX OR MINGW)
-
- #sources
-diff --git a/common/stream.c b/common/stream.c
-index 18c1ebf..242174a 100644
---- a/common/stream.c
-+++ b/common/stream.c
-@@ -61,10 +61,12 @@ static bool file_seek(void *data, off64_t offset, int origin)
- {
- #ifdef _MSC_VER
- return _fseeki64(data, offset, origin) == 0;
-+#elif defined __unix__
-+ return fseeko(data, offset, origin) == 0;
- #else
-- if (offset > INT32_MAX)
-- return false;
-- return fseek(data, (long)offset, origin) == 0;
-+ if (offset > INT32_MAX)
-+ return false;
-+ return fseek(data, (long)offset, origin) == 0;
- #endif
- }
-
-@@ -72,6 +74,8 @@ static off64_t file_tell(void *data)
- {
- #ifdef _MSC_VER
- return _ftelli64(data);
-+#elif defined __unix__
-+ return ftello(data);
- #else
- return ftell(data);
- #endif