summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD44
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bcce9b34ecc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libupnp-git
+ pkgdesc = Portable open source UPnP development kit
+ pkgver = 1.8.2.r12.gf07f078
+ pkgrel = 1
+ url = http://pupnp.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = glibc
+ provides = libupnp
+ conflicts = libupnp
+ options = staticlibs
+ source = git+https://git.code.sf.net/p/pupnp/code
+ sha256sums = SKIP
+
+pkgname = libupnp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0f8e91aac1ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libupnp-git
+pkgver=1.8.2.r12.gf07f078
+pkgrel=1
+pkgdesc="Portable open source UPnP development kit"
+arch=('i686' 'x86_64')
+url="http://pupnp.sourceforge.net/"
+license=('BSD')
+depends=('glibc')
+makedepends=('git')
+provides=('libupnp')
+conflicts=('libupnp')
+options=('staticlibs')
+source=("git+https://git.code.sf.net/p/pupnp/code")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "code"
+
+ git describe --long --tags | sed 's/^release-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "code"
+
+ ./bootstrap
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "code"
+
+ #make check
+}
+
+package() {
+ cd "code"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libupnp/LICENSE"
+}