summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 147252b5c8a4..f8be433a9d0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
-# Generated by mksrcinfo v8
-# Thu Jun 21 05:37:34 UTC 2018
pkgbase = libusbgx
pkgdesc = Library encapsulating the kernel USB gadget-configfs userspace API functionality
pkgver = 0.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/libusbgx/libusbgx/
- arch = i686
arch = x86_64
license = GPL2
makedepends = automake
depends = libconfig
source = libusbgx-0.2.0.tar.gz::https://github.com/libusbgx/libusbgx/archive/libusbgx-v0.2.0.tar.gz
+ source = https://github.com/libusbgx/libusbgx/commit/b5ad66eb1e46281981adb33a38e9c5a2767c0c44.patch
+ source = https://github.com/libusbgx/libusbgx/commit/45c14ef4d5d7ced0fbf984208de44ced6d5ed898.patch
sha256sums = b15abc89a0ef82c6a650cc1d58b5ba50f7ce076db392add84caabcd86c608ee2
+ sha256sums = 61fe8b0a56a72cea71cc57e964c8489c860c0148957e0d1599f790d86cac5a73
+ sha256sums = 6257f537cbf4f471d974333cc3a5ac06431d63a14210189244dcfc8625ea77dc
pkgname = libusbgx
-
diff --git a/PKGBUILD b/PKGBUILD
index 92080f36d034..cada04181ef3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,24 @@
pkgname=libusbgx
pkgver=0.2.0
-pkgrel=1
+pkgrel=2
pkgdesc='Library encapsulating the kernel USB gadget-configfs userspace API functionality'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/libusbgx/libusbgx/'
depends=('libconfig')
makedepends=('automake')
license=('GPL2')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/libusbgx/libusbgx/archive/libusbgx-v${pkgver}.tar.gz")
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/libusbgx/libusbgx/archive/libusbgx-v${pkgver}.tar.gz"
+ "https://github.com/libusbgx/libusbgx/commit/b5ad66eb1e46281981adb33a38e9c5a2767c0c44.patch"
+ "https://github.com/libusbgx/libusbgx/commit/45c14ef4d5d7ced0fbf984208de44ced6d5ed898.patch"
+)
+
+prepare() {
+ cd "${srcdir}/libusbgx-libusbgx-v${pkgver}"
+ patch -p1 < "${srcdir}/"b5ad66eb1e46281981adb33a38e9c5a2767c0c44.patch
+ patch -p1 < "${srcdir}/"45c14ef4d5d7ced0fbf984208de44ced6d5ed898.patch
+}
build() {
cd "${srcdir}/libusbgx-libusbgx-v${pkgver}"
@@ -25,4 +35,6 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha256sums=('b15abc89a0ef82c6a650cc1d58b5ba50f7ce076db392add84caabcd86c608ee2')
+sha256sums=('b15abc89a0ef82c6a650cc1d58b5ba50f7ce076db392add84caabcd86c608ee2'
+ '61fe8b0a56a72cea71cc57e964c8489c860c0148957e0d1599f790d86cac5a73'
+ '6257f537cbf4f471d974333cc3a5ac06431d63a14210189244dcfc8625ea77dc')