summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f617563be0..be74775f2dfc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libuv-git
pkgdesc = A multi-platform support library with a focus on asynchronous I/O
- pkgver = 1.13.1.r67.g9834c4f7
- pkgrel = 2
+ pkgver = 1.18.0.r69.g70d61b6c
+ pkgrel = 1
url = http://libuv.org/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ce95f191c947..1e18fcfcc2e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libuv-git
-pkgver=1.13.1.r67.g9834c4f7
-pkgrel=2
+pkgver=1.18.0.r69.g70d61b6c
+pkgrel=1
pkgdesc="A multi-platform support library with a focus on asynchronous I/O"
arch=('i686' 'x86_64')
url="http://libuv.org/"
@@ -19,7 +19,10 @@ sha256sums=('SKIP')
pkgver() {
cd "libuv"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/v//p}')
+ _rev=$(git rev-list --count v$_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
}
build() {