summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD46
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf1b68b254a0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = libuv-git
+ pkgdesc = A multi-platform support library with a focus on asynchronous I/O
+ pkgver = 1.13.1.r67.g9834c4f7
+ pkgrel = 1
+ url = http://libuv.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = python-sphinx
+ depends = glibc
+ provides = libuv
+ conflicts = libuv
+ source = git+https://github.com/libuv/libuv.git#branch=master
+ sha256sums = SKIP
+
+pkgname = libuv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50e1b2df964f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libuv-git
+pkgver=1.13.1.r67.g9834c4f7
+pkgrel=1
+pkgdesc="A multi-platform support library with a focus on asynchronous I/O"
+arch=('i686' 'x86_64')
+url="http://libuv.org/"
+license=('MIT')
+depends=('glibc')
+makedepends=('git' 'python-sphinx')
+provides=('libuv')
+conflicts=('libuv')
+source=("git+https://github.com/libuv/libuv.git#branch=master")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libuv"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libuv"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+ make -C "docs" man
+}
+
+check() {
+ cd "libuv"
+
+ make check
+}
+
+package() {
+ cd "libuv"
+
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 "docs/build/man/libuv.1" "$pkgdir/usr/share/man/man1/libuv.1"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libuv/LICENSE"
+}