summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 54070b9712de..0294486736e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = libuv-git
pkgdesc = A multi-platform support library with a focus on asynchronous I/O
- pkgver = 1.23.0.r83.g6e7da5fb
+ pkgver = 1.39.0.r100.gdec07238
pkgrel = 1
url = https://libuv.org/
arch = i686
@@ -9,7 +9,6 @@ pkgbase = libuv-git
makedepends = git
makedepends = python-sphinx
depends = glibc
- depends = libnsl
provides = libuv
conflicts = libuv
options = staticlibs
diff --git a/PKGBUILD b/PKGBUILD
index fa9b10739467..58e29eae9321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libuv-git
-pkgver=1.23.0.r83.g6e7da5fb
+pkgver=1.39.0.r100.gdec07238
pkgrel=1
pkgdesc="A multi-platform support library with a focus on asynchronous I/O"
arch=('i686' 'x86_64')
url="https://libuv.org/"
license=('MIT')
-depends=('glibc' 'libnsl')
+depends=('glibc')
makedepends=('git' 'python-sphinx')
provides=('libuv')
conflicts=('libuv')
@@ -19,17 +19,18 @@ sha256sums=('SKIP')
pkgver() {
cd "libuv"
- _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/v//p}')
- _rev=$(git rev-list --count v$_tag..HEAD)
+ _tag=$(git tag -l --sort -v:refname | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
cd "libuv"
./autogen.sh
- ./configure --prefix="/usr"
+ ./configure \
+ --prefix="/usr"
make
make -C "docs" man
}
@@ -45,6 +46,6 @@ package() {
make DESTDIR="$pkgdir" install
- install -Dm644 "docs/build/man/libuv.1" "$pkgdir/usr/share/man/man1/libuv.1"
- install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/libuv/LICENSE"
+ install -Dm644 "docs/build/man/libuv.1" -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/libuv"
}