summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD36
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52eafcb31a42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = libva-hantro-h264-git
+ pkgdesc = Video Acceleration (VA) API for Linux (Hantro H264 support, git version)
+ pkgver = r1580.0b8a288
+ pkgrel = 1
+ url = https://github.com/pH5/libva/tree/hantro-h264
+ arch = aarch64
+ license = MIT
+ makedepends = git
+ makedepends = libglvnd
+ makedepends = mesa
+ makedepends = meson
+ depends = libdrm
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = libxfixes
+ depends = wayland
+ optdepends = libva-vdpau-driver: backend for Nvidia and AMD cards
+ optdepends = libva-intel-driver: backend for Intel cards
+ provides = libva
+ provides = libva-drm.so
+ provides = libva-glx.so
+ provides = libva-wayland.so
+ provides = libva-x11.so
+ provides = libva.so
+ conflicts = libva
+ source = git+https://github.com/pH5/libva.git#branch=hantro-h264
+ sha256sums = SKIP
+
+pkgname = libva-hantro-h264-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae3085cb4814
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Andre Vallestero < gmail-com: andrevallestero >
+
+pkgname=libva-hantro-h264-git
+_srcname=libva
+pkgver=r1580.0b8a288
+pkgrel=1
+pkgdesc='Video Acceleration (VA) API for Linux (Hantro H264 support, git version)'
+arch=('aarch64')
+url='https://github.com/pH5/libva/tree/hantro-h264'
+license=('MIT')
+depends=('libdrm' 'libgl' 'libx11' 'libxext' 'libxfixes' 'wayland')
+makedepends=('git' 'libglvnd' 'mesa' 'meson')
+optdepends=('libva-vdpau-driver: backend for Nvidia and AMD cards'
+ 'libva-intel-driver: backend for Intel cards')
+provides=('libva' 'libva-drm.so' 'libva-glx.so' 'libva-wayland.so'
+ 'libva-x11.so' 'libva.so')
+conflicts=('libva')
+source=('git+https://github.com/pH5/libva.git#branch=hantro-h264')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_srcname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_srcname"
+ arch-meson . build
+ ninja -C build
+}
+
+package() {
+ cd "$_srcname"
+ DESTDIR="$pkgdir" ninja -C build install
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}