summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD32
-rw-r--r--accept-line-folding.diff23
-rw-r--r--count-vcards-buffer-overflow.diff40
-rw-r--r--field-names-comply-with-vCard2.1diff25
-rw-r--r--manpage-Lb-definition.diff16
5 files changed, 0 insertions, 136 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 908e7c9529ff..09737808fa9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,25 +16,8 @@ source=("$url/archive/v$pkgver.tar.gz"
validpgpkeys=('3F464391498FE874BDB5D98F2124AA1983785C90')
-#source=(
-# http://downloads.sourceforge.net/rolo/$pkgname-$pkgver.tar.gz
-# count-vcards-buffer-overflow.diff
-# field-names-comply-with-vCard2.1diff
-# manpage-Lb-definition.diff
-# accept-line-folding.diff
-#)
-
-# Patches originate from
-# https://anonscm.debian.org/cgit/users/rafael/deb-pkg/libvc.git/
-# but I don't want to rely on the source being available.
-
build() {
cd ${srcdir}/${pkgname}-${pkgver}
-
-#patch -p1 -i ../count-vcards-buffer-overflow.diff
-#patch -p1 -i ../field-names-comply-with-vCard2.1diff
-#patch -p1 -i ../manpage-Lb-definition.diff
-#patch -p1 -i ../accept-line-folding.diff
autoreconf -f -i
./configure --prefix=/usr
@@ -51,20 +34,5 @@ package() {
make DESTDIR=${pkgdir} install
}
-#md5sums=(
-# '3c9f0fb512d02d179f57a9eadcfa1043'
-# '98b3c99555f1e69a0d07152cb800da4f'
-# 'd5bd5ff0720cc726998694c2e01e495e'
-# '1366acdbc5569cd18079d823eb91782c'
-# '8cf005aac291836e574751f49b5fa32b'
-#)
-
-#sha256sums=(
-# 'c5e75ff0ad63b723179dfcc62849adedcfa575473b784f3bca982b2c481e0b9b'
-# '78466514046a2c04e3c50b51d4a8e1d7c0f4ae781b0d1221078b9e9ba46dbab2'
-# 'bfeb6c52aece423646454ca17905fdf2c351eb56fa19a79db51c4c0c08420c5e'
-# '08798202bcc7c8453eeb13f5328ec1a135527f55920b67d05ec1674692191691'
-# '62e8ab67b03d4140ced02ec894a460bf3a0d06f86f1d4ab804132d71cc8b0e7d'
-#)
md5sums=('4fb0ba25badf35fcf394513734e98048'
'SKIP')
diff --git a/accept-line-folding.diff b/accept-line-folding.diff
deleted file mode 100644
index c9ed39e40008..000000000000
--- a/accept-line-folding.diff
+++ /dev/null
@@ -1,23 +0,0 @@
-Make the flex scanner accept values of the fields spanning
-several lines using the folding technique of RFC-822 (i.e. using
-a space in the beginning of the continuation lines. This does
-not yet make libvc completely RFC-2425-compliant, because the
-continuation sequence "\n " is still contained in the
-output (i.e. not eaten up). At any rate, rolo should now be able
-to read vCard files containing folded lines (closes: #442944).
-
- -- Rafael Laboissiere <rafael@debian.org> Tue, 01 Jul 2008 17:10:33 +0200
-
-Index: libvc-003.dfsg.1/src/vc_scan.l
-===================================================================
---- libvc-003.dfsg.1.orig/src/vc_scan.l 2008-07-01 17:28:46.000000000 +0200
-+++ libvc-003.dfsg.1/src/vc_scan.l 2008-07-01 17:28:54.000000000 +0200
-@@ -67,7 +67,7 @@
-
- <SC_VALUE>
- {
--{VALUE-CHAR}* { yylval = yytext; return TOK_VALUE; }
-+({VALUE-CHAR}|"\n ")* { yylval = yytext; return TOK_VALUE; }
- "\n" { yylval = NULL; BEGIN(INITIAL); return yytext[0]; }
- }
-
diff --git a/count-vcards-buffer-overflow.diff b/count-vcards-buffer-overflow.diff
deleted file mode 100644
index d2841d736841..000000000000
--- a/count-vcards-buffer-overflow.diff
+++ /dev/null
@@ -1,40 +0,0 @@
-Fix buffer overflow problem, as reported in
-http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-1356
-
- -- Rafael Laboissiere <rafael@debian.org> Tue, 01 Jul 2008 17:10:33 +0200
-
-Index: libvc-003.dfsg.1/src/vc.c
-===================================================================
---- libvc-003.dfsg.1.orig/src/vc.c 2008-07-01 17:19:22.000000000 +0200
-+++ libvc-003.dfsg.1/src/vc.c 2008-07-01 17:19:24.000000000 +0200
-@@ -25,6 +25,7 @@
- #include "vc.h"
- #include <stdlib.h>
- #include <string.h>
-+#define __USE_GNU
- #include <stdio.h>
-
- #define BUF_LEN 80
-@@ -832,14 +833,16 @@
- int
- count_vcards (FILE * fp)
- {
-- char buf[256];
-+ char* line = NULL;
-+ size_t len = 0;
- int counter = 0;
-
-- while (EOF != fscanf (fp, "%s\n", buf))
-- {
-- if (0 == strcasecmp (buf, "BEGIN:VCARD"))
-- counter++;
-- }
-+ while (getline (&line, &len, fp) != EOF)
-+ if (0 == strncasecmp (line, "BEGIN:VCARD", 11))
-+ counter++;
-+
-+ if (line)
-+ free (line);
-
- return counter;
- }
diff --git a/field-names-comply-with-vCard2.1diff b/field-names-comply-with-vCard2.1diff
deleted file mode 100644
index 5b32c97dc64c..000000000000
--- a/field-names-comply-with-vCard2.1diff
+++ /dev/null
@@ -1,25 +0,0 @@
-Change lex scanning variables, complying with VCard-2
-
- -- Rafael Laboissiere <rafael@debian.org> Tue, 01 Jul 2008 17:10:33 +0200
-
-Index: libvc-003.dfsg.1/src/vc_scan.l
-===================================================================
---- libvc-003.dfsg.1.orig/src/vc_scan.l 2008-07-01 17:20:04.000000000 +0200
-+++ libvc-003.dfsg.1/src/vc_scan.l 2008-07-01 17:20:10.000000000 +0200
-@@ -49,6 +49,7 @@
- NON-ASCII [\x80-\xFF]
- SAFE-CHAR {WSP}|\x21|[\x23-\x2B]|[\x2D-\x39]|[\x3C-\x7E]|{NON-ASCII}
- VALUE-CHAR {WSP}|{VCHAR}|{NON-ASCII}
-+NAME-CHAR [\x21-\x2B\x2D\x2F-\x39\x3C\x3E-\x5A\x5C\x5E-\x7E]
-
- %option noyywrap
- %x SC_VALUE SC_PARAM SC_PARAM_VALUE
-@@ -60,7 +61,7 @@
- "\n" { yylval = NULL; return yytext[0]; }
- "." { yylval = NULL; return yytext[0]; }
- ({ALPHA}|{DIGIT}|-)+/"." { yylval = yytext; return TOK_GROUP; }
--({ALPHA}|{DIGIT}|-)+ { yylval = yytext; return TOK_NAME; }
-+{NAME-CHAR}+ { yylval = yytext; return TOK_NAME; }
- ";" { yylval = NULL; BEGIN(SC_PARAM); return yytext[0]; }
- ":" { yylval = NULL; BEGIN(SC_VALUE); return yytext[0]; }
-
diff --git a/manpage-Lb-definition.diff b/manpage-Lb-definition.diff
deleted file mode 100644
index ae1c00fe4155..000000000000
--- a/manpage-Lb-definition.diff
+++ /dev/null
@@ -1,16 +0,0 @@
-Adds definition for the libvc library (.Lb macro) and avoids nroff warnings
-
- -- Rafael Laboissiere <rafael@debian.org> Tue, 01 Jul 2008 17:10:33 +0200
-
-Index: libvc-003.dfsg.1/doc/vc.3
-===================================================================
---- libvc-003.dfsg.1.orig/doc/vc.3 2008-07-01 17:20:46.000000000 +0200
-+++ libvc-003.dfsg.1/doc/vc.3 2008-07-01 17:20:54.000000000 +0200
-@@ -44,6 +44,7 @@
- .Nm get_val_struct_part
- .Nd vCard library
- .Sh LIBRARY
-+.ds str-Lb-libvc vCard\~library (libvc, \-lvc)
- .Lb libvc
- .Sh SYNOPSIS
- .In vc.h