summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66a0ec982a28
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = libvdpau-sunxi
+ pkgdesc = VDPAU driver for Allwinner sunxi SoCs
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://github.com/linux-sunxi/libvdpau-sunxi
+ arch = armv7h
+ license = LGPL
+ makedepends = libvdpau
+ depends = libx11
+ source = https://github.com/linux-sunxi/libvdpau-sunxi/archive/v0.3.tar.gz
+ sha256sums = 8a29b2b5394e9ad5f461af48cea780d3cb183bfc80399e58a27b632c1a9d5bab
+
+pkgname = libvdpau-sunxi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b537869696f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jens Kuske <jenskuske@gmail.com>
+# Contributor: smotocel69 <smotocel69@gmail.com>
+pkgname=libvdpau-sunxi
+pkgver=0.3
+pkgrel=1
+pkgdesc="VDPAU driver for Allwinner sunxi SoCs"
+arch=('armv7h')
+url="https://github.com/linux-sunxi/libvdpau-sunxi"
+license=('LGPL')
+depends=('libx11')
+makedepends=('libvdpau')
+source=("https://github.com/linux-sunxi/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('8a29b2b5394e9ad5f461af48cea780d3cb183bfc80399e58a27b632c1a9d5bab')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}