summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4f142b686bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = libvlc
+ pkgdesc = The VLC library not bundled with VLC so one can use things depending on the lib without installing VLC
+ pkgver = 5.6.0
+ pkgrel = 1
+ url = https://www.videolan.org/LibVLC/
+ arch = x86_64
+ license = LGPL
+ depends = libvlccore
+ source = https://mex.mirror.pkgbuild.com/extra/os/x86_64/vlc-3.0.1-2-x86_64.pkg.tar.xz
+ md5sums = a906947ae388875fdd08a68ac6ee4c1c
+
+pkgname = libvlc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a530db13f20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: E5ten
+
+pkgname=libvlc
+pkgver=5.6.0
+pkgrel=1
+pkgdesc="The VLC library not bundled with VLC so one can use things depending on the lib without installing VLC"
+arch=('x86_64')
+url='https://www.videolan.org/LibVLC/'
+license=('LGPL')
+depends=('libvlccore')
+source=("https://mex.mirror.pkgbuild.com/extra/os/x86_64/vlc-3.0.1-2-x86_64.pkg.tar.xz")
+md5sums=('a906947ae388875fdd08a68ac6ee4c1c')
+
+package() {
+ cd $srcdir/usr/lib
+ mkdir -p $pkgdir/usr/lib
+ cp libvlc.so.$pkgver $pkgdir/usr/lib/
+ ln -s /usr/lib/libvlc.so.$pkgver $pkgdir/usr/lib/libvlc.so.5
+ ln -s /usr/lib/libvlc.so.$pkgver $pkgdir/usr/lib/libvlc.so
+} \ No newline at end of file