summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..587acbcd6ea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libvorbis-git
+ pkgdesc = Reference implementation of the Ogg Vorbis audio format
+ pkgver = 1.3.5.r47.g143caf4
+ pkgrel = 1
+ url = http://www.vorbis.com/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ depends = libogg
+ provides = libvorbis
+ provides = libvorbisfile.so
+ provides = libvorbis.so
+ provides = libvorbisenc.so
+ conflicts = libvorbis
+ source = git+https://git.xiph.org/vorbis.git
+ sha256sums = SKIP
+
+pkgname = libvorbis-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8123cf5b6596
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libvorbis-git
+pkgver=1.3.5.r47.g143caf4
+pkgrel=1
+pkgdesc="Reference implementation of the Ogg Vorbis audio format"
+arch=('i686' 'x86_64')
+url="http://www.vorbis.com/"
+license=('BSD')
+depends=('libogg')
+makedepends=('git')
+provides=('libvorbis' 'libvorbisfile.so' 'libvorbis.so' 'libvorbisenc.so')
+conflicts=('libvorbis')
+source=("git+https://git.xiph.org/vorbis.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "vorbis"
+
+ git describe --long --tags | sed 's/^[A-Za-z]*//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "vorbis"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+
+ make
+}
+
+check() {
+ cd "vorbis"
+
+ make check
+}
+
+package() {
+ cd "vorbis"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/libvorbis/COPYING"
+}