summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--site.py.patch18
3 files changed, 28 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 643d8a9636d1..f43e8bc743b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Dec 18 20:21:48 UTC 2015
+# Tue Jan 19 15:22:32 UTC 2016
pkgbase = libx32-python
pkgdesc = Next generation of the python high-level scripting language (x32 ABI)
pkgver = 3.5.1
- pkgrel = 1.1
+ pkgrel = 1.2
url = http://www.python.org/
arch = x86_64
license = custom
@@ -32,10 +32,12 @@ pkgbase = libx32-python
source = http://www.python.org/ftp/python/3.5.1/Python-3.5.1.tar.xz
source = pyconfig-stub.h
source = venv-x32.patch
+ source = site.py.patch
source = dont-make-libpython-readonly.patch
sha1sums = 0186da436db76776196612b98bb9c2f76acfe90e
sha1sums = 74e5b55b394b1dfe5c430734e2ce049d595fb50f
sha1sums = af6b854349f4992892471b9cb363e8a6ce19ea6b
+ sha1sums = f0fe25082c2b080dccf19400fe998d97f3adf5a4
sha1sums = c22b24324b8e53326702de439c401d97927ee3f2
pkgname = libx32-python
diff --git a/PKGBUILD b/PKGBUILD
index 267fc3d31fd8..f043208fcbe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_pkgbasename=python
pkgname=libx32-python
pkgver=3.5.1
-pkgrel=1.1
+pkgrel=1.2
_pybasever=3.5
pkgdesc="Next generation of the python high-level scripting language (x32 ABI)"
arch=('x86_64')
@@ -28,10 +28,12 @@ options=('!makeflags')
source=("http://www.python.org/ftp/python/${pkgver%rc*}/Python-${pkgver}.tar.xz"
pyconfig-stub.h
venv-x32.patch
+ site.py.patch
dont-make-libpython-readonly.patch)
sha1sums=('0186da436db76776196612b98bb9c2f76acfe90e'
'74e5b55b394b1dfe5c430734e2ce049d595fb50f'
'af6b854349f4992892471b9cb363e8a6ce19ea6b'
+ 'f0fe25082c2b080dccf19400fe998d97f3adf5a4'
'c22b24324b8e53326702de439c401d97927ee3f2')
prepare() {
@@ -43,6 +45,9 @@ prepare() {
# x32 venv
patch -p1 -i ../venv-x32.patch
+ # site.py
+ patch -p1 -i ../site.py.patch
+
# FS#23997
sed -i -e "s|^#.* /usr/local/bin/python|#!/usr/bin/python-x32|" Lib/cgi.py
diff --git a/site.py.patch b/site.py.patch
new file mode 100644
index 000000000000..6957be3a5fe6
--- /dev/null
+++ b/site.py.patch
@@ -0,0 +1,18 @@
+diff -ru Python-3.5.1/Lib/site.py Python-3.5.1.changed/Lib/site.py
+--- Python-3.5.1/Lib/site.py 2015-12-07 09:39:08.000000000 +0800
++++ Python-3.5.1.changed/Lib/site.py 2016-01-19 23:20:14.729999998 +0800
+@@ -303,12 +303,12 @@
+ seen.add(prefix)
+
+ if os.sep == '/':
+- sitepackages.append(os.path.join(prefix, "lib",
++ sitepackages.append(os.path.join(prefix, "libx32",
+ "python" + sys.version[:3],
+ "site-packages"))
+ else:
+ sitepackages.append(prefix)
+- sitepackages.append(os.path.join(prefix, "lib", "site-packages"))
++ sitepackages.append(os.path.join(prefix, "libx32", "site-packages"))
+ if sys.platform == "darwin":
+ # for framework builds *only* we add the standard Apple
+ # locations.