aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD35
-rw-r--r--README.md4
-rw-r--r--libx52.install6
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..887055af7024
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = libx52
+ pkgdesc = Application to control the MFD and LEDs of a Saitek X52/X52Pro HOTAS
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://github.com/nirenjan/x52pro-linux
+ install = libx52.install
+ arch = x86_64
+ license = GPL2
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = libtool
+ makedepends = pkg-config
+ makedepends = python
+ makedepends = gettext
+ makedepends = libusb
+ makedepends = hidapi
+ makedepends = libevdev
+ makedepends = doxygen
+ makedepends = rsync
+ makedepends = cmocka
+ makedepends = git
+ depends = libusb
+ depends = hidapi
+ depends = libevdev
+ source = https://github.com/nirenjan/x52pro-linux/releases/download/v0.2.3/x52pro-linux_0.2.3.orig.tar.gz
+ sha256sums = 2ef00c521413a7f87581356e502ffe04196e22e951374a49b6eabb03cb76a9d4
+
+pkgname = libx52
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a470f4a40080
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Nirenjan Krishnan <nirenjan@gmail.com>
+
+pkgname=libx52
+_gitname=x52pro-linux
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="Application to control the MFD and LEDs of a Saitek X52/X52Pro HOTAS"
+arch=('x86_64')
+url="https://github.com/nirenjan/${_gitname}"
+license=('GPL2')
+depends=('libusb' 'hidapi' 'libevdev')
+makedepends=('autoconf' 'automake' 'libtool' 'pkg-config' 'python'
+ 'gettext' 'libusb' 'hidapi' 'libevdev' 'doxygen' 'rsync' 'cmocka' 'git')
+install="${pkgname}.install"
+source=("https://github.com/nirenjan/x52pro-linux/releases/download/v${pkgver}/${_gitname}_${pkgver}.orig.tar.gz")
+sha256sums=('2ef00c521413a7f87581356e502ffe04196e22e951374a49b6eabb03cb76a9d4')
+
+build() {
+ cd ${srcdir}/${_gitname}-${pkgver}
+ mkdir build
+ cd build
+ ../configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc \
+ --disable-silent-rules --disable-maintainer-mode
+ make
+}
+
+package() {
+ cd ${srcdir}/${_gitname}-${pkgver}/build
+
+ make install DESTDIR="${pkgdir}"
+
+ # Delete the /var/run and /var/log directories, they are owned by the system
+ rmdir "${pkgdir}/var/run"
+ rmdir "${pkgdir}/var/log"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..4b0640051aef
--- /dev/null
+++ b/README.md
@@ -0,0 +1,4 @@
+PKGBUILD for AUR
+================
+
+This repository contains the PKGBUILD for the Arch user repository (AUR).
diff --git a/libx52.install b/libx52.install
new file mode 100644
index 000000000000..9f51136195b6
--- /dev/null
+++ b/libx52.install
@@ -0,0 +1,6 @@
+post_install()
+{
+ echo "$(tput setaf 4)To use libx52 as non-root user, you need to reload the udev rules$(tput sgr0)"
+ echo "$(tput setaf 2)sudo udevadm control --reload-rules$(tput sgr0)"
+ echo "$(tput setaf 2)sudo udevadm trigger --subsystem-match=usb --attr-match=idVendor=06a3 --action=add$(tput sgr0)"
+}