summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc3b04cc8dbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = libximc7
+ pkgdesc = Library for controlling stepper and other motors. It provides a simple C interface for controlling and configuring engine and controller. It uses a common virtual serial port driver embedded in all OS.
+ pkgver = 2.9.7
+ pkgrel = 1
+ url = https://en.xisupport.com/projects/enxisupport/wiki/Software
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = glibc>=2.14
+ source_i686 = http://download.ximc.ru/libximc7/libximc7-2.9.7-i386.deb
+ sha256sums_i686 = 68eebf7075ce5466a4db4d522d555aa9f832ad44a0322af3c999931df31caff0
+ source_x86_64 = http://download.ximc.ru/libximc7/libximc7-2.9.7-amd64.deb
+ sha256sums_x86_64 = fb69f4cedfc165e6e6f8101933d74fb5058a10c9ae7751b49ba444b0fe764bbc
+
+pkgname = libximc7
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca1957cb95b1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+pkgname=libximc7
+pkgver=2.9.7
+pkgrel=1
+pkgdesc="Library for controlling stepper and other motors.
+It provides a simple C interface for controlling and configuring engine and controller.
+It uses a common virtual serial port driver embedded in all OS."
+arch=('i686' 'x86_64')
+url="https://en.xisupport.com/projects/enxisupport/wiki/Software"
+depends=('glibc>=2.14')
+license=('custom')
+source_i686=("http://download.ximc.ru/libximc7/libximc7-${pkgver}-i386.deb")
+sha256sums_i686=('68eebf7075ce5466a4db4d522d555aa9f832ad44a0322af3c999931df31caff0')
+source_x86_64=("http://download.ximc.ru/libximc7/libximc7-${pkgver}-amd64.deb")
+sha256sums_x86_64=('fb69f4cedfc165e6e6f8101933d74fb5058a10c9ae7751b49ba444b0fe764bbc')
+
+package() {
+ cd "${srcdir}"
+
+ tar -xzC "${pkgdir}" -f data.tar.gz
+
+ cp -r ${pkgdir}/lib ${pkgdir}/usr/
+ rm -r ${pkgdir}/lib
+}