summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..224e98134f41
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = libxpm-git
+ pkgdesc = X pixmap (XPM) image file format library
+ pkgver = 3.5.13.r2.g83e5427
+ pkgrel = 1
+ url = https://xorg.freedesktop.org/wiki/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = xorg-util-macros
+ depends = glibc
+ depends = libxext
+ depends = libxt
+ provides = libxpm
+ conflicts = libxpm
+ options = staticlibs
+ source = git+https://gitlab.freedesktop.org/xorg/lib/libxpm.git
+ sha256sums = SKIP
+
+pkgname = libxpm-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..25de07bc87a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libxpm-git
+pkgver=3.5.13.r2.g83e5427
+pkgrel=1
+pkgdesc="X pixmap (XPM) image file format library"
+arch=('i686' 'x86_64')
+url="https://xorg.freedesktop.org/wiki/"
+license=('custom')
+depends=('glibc' 'libxext' 'libxt')
+makedepends=('git' 'xorg-util-macros')
+provides=('libxpm')
+conflicts=('libxpm')
+options=('staticlibs')
+source=("git+https://gitlab.freedesktop.org/xorg/lib/libxpm.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "libxpm"
+
+ git describe --long --tags | sed 's/^libXpm-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "libxpm"
+
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure \
+ --prefix="/usr"
+ make
+}
+
+package() {
+ cd "libxpm"
+
+ make DESTDIR="$pkgdir" install
+ install -Dm644 "COPYING" -t "$pkgdir/usr/share/licenses/libxpm"
+}