summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD29
2 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50a90342b133..4bd54140576a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = libxrandr-git
pkgdesc = X11 RandR extension library. Git version.
- pkgver = 1.5.0
+ pkgver = 1.5.2.r7.g7181160
pkgrel = 1
url = http://xorg.freedesktop.org
arch = i686
arch = x86_64
license = custom
makedepends = xorg-util-macros
+ makedepends = xorgproto
makedepends = git
depends = libxext
depends = libxrender
- depends = randrproto>=1.5.0
- provides = libxrandr=1.5.0
+ provides = libxrandr=1.5.2.r7.g7181160
conflicts = libxrandr
- source = libxrandr::git+http://anongit.freedesktop.org/git/xorg/lib/libXrandr.git
+ source = libxrandr::git+https://gitlab.freedesktop.org/xorg/lib/libxrandr.git
md5sums = SKIP
pkgname = libxrandr-git
-
diff --git a/PKGBUILD b/PKGBUILD
index dae8d7b7509a..f51b12129373 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,34 @@
-# Maintainer: James An <james@jamesan.ca>o
+# Maintainer: Avery Warddhana <them+arch _ nullablevo id au>
+# Contributor: James An <james@jamesan.ca>o
# Contributor: Jan de Groot <jgc@archlinux.org>
# Contributor: Andreas Radke <andyrtr@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
_pkgname=libxrandr
pkgname=libxrandr-git
-pkgver=1.5.0
+pkgver=1.5.2.r7.g7181160
pkgrel=1
pkgdesc='X11 RandR extension library. Git version.'
arch=('i686' 'x86_64')
license=('custom')
url='http://xorg.freedesktop.org'
-depends=('libxext' 'libxrender' 'randrproto>=1.5.0')
-makedepends=('xorg-util-macros' 'git')
+depends=('libxext' 'libxrender')
+makedepends=('xorg-util-macros' 'xorgproto' 'git')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-source=("$_pkgname"::'git+http://anongit.freedesktop.org/git/xorg/lib/libXrandr.git')
+source=("$_pkgname"::'git+https://gitlab.freedesktop.org/xorg/lib/libxrandr.git')
md5sums=('SKIP')
-# Version 1.5+ have not been tagged yet, so the pkgver() would a previous minor release number.
-#~ pkgver() {
- #~ cd "$_pkgname"
- #~ (
- #~ set -o pipefail
- #~ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- #~ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- #~ )
-#~ }
+pkgver() {
+ cd "$_pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g;s/^libXrandr.//' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
build() {
cd "$_pkgname"
-
./autogen.sh
./configure --prefix=/usr --sysconfdir=/etc
make